aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/ipset/ipset_7.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter/ipset/ipset_7.21.bb')
-rw-r--r--meta-networking/recipes-filter/ipset/ipset_7.21.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/ipset/ipset_7.21.bb b/meta-networking/recipes-filter/ipset/ipset_7.21.bb
new file mode 100644
index 0000000000..c7ebdc1c66
--- /dev/null
+++ b/meta-networking/recipes-filter/ipset/ipset_7.21.bb
@@ -0,0 +1,22 @@
+# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Administration tool for IP sets"
+HOMEPAGE = "http://ipset.netfilter.org"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+SECTION = "base"
+
+DEPENDS = "libtool libmnl"
+
+SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2 \
+ file://0001-ipset-Define-portable-basename-function.patch"
+SRC_URI[sha256sum] = "e2c6ce4fcf3acb3893ca5d35c86935f80ad76fc5ccae601185842df760e0bc69"
+
+inherit autotools pkgconfig module-base
+
+EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
+
+RRECOMMENDS:${PN} = "\
+ kernel-module-ip-set \
+"