aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/keepalived
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/keepalived')
-rw-r--r--meta-networking/recipes-daemons/keepalived/keepalived_2.2.8.bb (renamed from meta-networking/recipes-daemons/keepalived/keepalived_1.4.2.bb)22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived_1.4.2.bb b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.8.bb
index 31c50ff6b8..85f4a6aa59 100644
--- a/meta-networking/recipes-daemons/keepalived/keepalived_1.4.2.bb
+++ b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.8.bb
@@ -7,12 +7,13 @@ Server (IPVS) kernel module providing Layer4 loadbalancing \
"
HOMEPAGE = "http://www.keepalived.org/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz"
-SRC_URI[md5sum] = "610af6e04071f02d3469191de7499f4e"
-SRC_URI[sha256sum] = "4e2d7cc01a6ee29a3955f5c622d47704ba7d9dd758189f15e9def016a2d1faa3"
+SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \
+ "
+SRC_URI[sha256sum] = "85882eb62974f395d4c631be990a41a839594a7e62fbfebcb5649a937a7a1bb6"
+UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases"
DEPENDS = "libnfnetlink openssl"
@@ -25,10 +26,11 @@ PACKAGECONFIG[libnl] = "--enable-libnl,--disable-libnl,libnl"
PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--with-init=SYSV,systemd"
-EXTRA_OECONF = "--disable-libiptc"
EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d"
-do_install_append() {
+export EXTRA_CFLAGS = "${CFLAGS}"
+
+do_install:append() {
if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then
chmod 0755 ${D}${sysconfdir}/init.d/${BPN}
sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN}
@@ -39,7 +41,11 @@ do_install_append() {
fi
}
-FILES_${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt"
+PACKAGE_BEFORE_PN = "${PN}-samples"
+
+FILES:${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt"
+
+FILES:${PN}-samples = "${sysconfdir}/keepalived/samples ${sysconfdir}/keepalived/keepalived.conf.sample"
-SYSTEMD_SERVICE_${PN} = "keepalived.service"
+SYSTEMD_SERVICE:${PN} = "keepalived.service"
SYSTEMD_AUTO_ENABLE ?= "disable"