aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/conf')
-rwxr-xr-xmeta-networking/conf/include/non-repro-meta-networking.inc59
-rw-r--r--meta-networking/conf/include/ptest-packagelists-meta-networking.inc37
-rw-r--r--meta-networking/conf/layer.conf11
3 files changed, 104 insertions, 3 deletions
diff --git a/meta-networking/conf/include/non-repro-meta-networking.inc b/meta-networking/conf/include/non-repro-meta-networking.inc
new file mode 100755
index 0000000000..e0f448fe31
--- /dev/null
+++ b/meta-networking/conf/include/non-repro-meta-networking.inc
@@ -0,0 +1,59 @@
+# List of known non-reproducible package of the meta-networking layer
+# Please keep this list sorted
+KNOWN_NON_REPRO_META_NETWORKING = " \
+ blueman \
+ blueman-dbg \
+ blueman-src \
+ civetweb-dev \
+ dhcp-relay-staticdev \
+ ettercap-src \
+ fetchmail \
+ fetchmail-dbg \
+ freediameter \
+ freediameter-src \
+ freeradius \
+ htpdate-doc \
+ keepalived \
+ keepalived-dbg \
+ kernel-module-mdio-netlink-6.6.17-yocto-standard \
+ libbearssl-staticdev \
+ libfko3 \
+ libfko-client \
+ libfko-daemon \
+ libfko-dbg \
+ libmosquitto1 \
+ libowfat-staticdev \
+ libruli-staticdev \
+ libsamba-util0 \
+ mdio-netlink-dbg \
+ mosquitto \
+ mosquitto-dbg \
+ ncftp \
+ ncftp-dbg \
+ ncftp-src \
+ ndisc6-dbg \
+ ndisc6-misc \
+ ndisc6-ndisc6 \
+ ndisc6-rdisc6 \
+ ndisc6-rdnssd \
+ ndisc6-rltraceroute6 \
+ netsniff-ng-doc \
+ ntpsec-src \
+ openl2tp \
+ openl2tp-dbg \
+ ot-br-posix \
+ ot-br-posix-dbg \
+ postfix-cfg \
+ proftpd \
+ proftpd-dbg \
+ proftpd-dev \
+ rdist \
+ rdist-dbg \
+ samba-dbg \
+ tayga \
+ tayga-dbg \
+ wolfssl \
+ wolfssl-dbg \
+ znc \
+ znc-doc \
+"
diff --git a/meta-networking/conf/include/ptest-packagelists-meta-networking.inc b/meta-networking/conf/include/ptest-packagelists-meta-networking.inc
new file mode 100644
index 0000000000..7ec6f9063d
--- /dev/null
+++ b/meta-networking/conf/include/ptest-packagelists-meta-networking.inc
@@ -0,0 +1,37 @@
+#
+# Lists of the ptest in meta-networking, sorted into two sets by the time they take
+# Please keep these sorted in alphabetical order
+#
+# A first pass at getting all meta-networking recipes which inherit ptest
+# meta_networking_ptest_recipes=$(bitbake-layers show-recipes --recipes-only --layer meta-networking --inherits ptest --bare | sed -e '1,/=== Matching recipes: ===/d')
+# ptests which take less than ~30s each
+
+PTESTS_FAST_META_NETWORKING = "\
+ freediameter \
+ geoip \
+ libcoap \
+ libldb \
+ libnftnl \
+ libtalloc \
+ libtdb \
+ lldpd \
+ mbedtls \
+ openhpi \
+ squid \
+ tcpdump \
+"
+
+# firewalld currently hangs forever so disable it for now
+# firewalld
+PTESTS_SLOW_META_NETWORKING = "\
+ net-snmp \
+"
+
+PTESTS_PROBLEMS_META_NETWORKING = "\
+ geoip-perl \
+ libtevent \
+ lksctp-tools \
+ nftables \
+ openl2tp \
+ python3-scapy \
+"
diff --git a/meta-networking/conf/layer.conf b/meta-networking/conf/layer.conf
index 2dfde4bdf4..0e09d8f2ad 100644
--- a/meta-networking/conf/layer.conf
+++ b/meta-networking/conf/layer.conf
@@ -13,12 +13,17 @@ BBFILE_PRIORITY_networking-layer = "5"
# cause compatibility issues with other layers
LAYERVERSION_networking-layer = "1"
-LAYERDEPENDS_networking-layer = "core"
-LAYERDEPENDS_networking-layer += "openembedded-layer"
-LAYERDEPENDS_networking-layer += "meta-python"
+LAYERDEPENDS_networking-layer = "core meta-python openembedded-layer"
+
+LAYERSERIES_COMPAT_networking-layer = "scarthgap styhead"
LICENSE_PATH += "${LAYERDIR}/licenses"
SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
wireguard-tools->wireguard-module \
+ mdio-tools->mdio-netlink \
+ ot-br-posix->ipset \
+"
+BBFILES_DYNAMIC += " \
+ meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
"