aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_46.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_46.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_46.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_46.0.bb b/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_46.0.bb
new file mode 100644
index 0000000000..5c7e27378c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_46.0.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GNOME calculator"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SECTION = "x11/gnome"
+
+DEPENDS = " \
+ yelp-tools-native \
+ gtk4 \
+ libsoup-3.0 \
+ libgee \
+ libxml2 \
+ libmpc \
+ gtksourceview5 \
+ libadwaita \
+"
+
+GIR_MESON_OPTION = 'disable-introspection'
+GIR_MESON_ENABLE_FLAG = 'false'
+GIR_MESON_DISABLE_FLAG = 'true'
+VALA_MESON_OPTION = ''
+
+GTKIC_VERSION = '4'
+
+inherit gnomebase gobject-introspection gnome-help vala gtk-icon-cache gettext features_check
+
+def gnome_verdir(v):
+ return oe.utils.trim_version(v, 1)
+
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
+
+SRC_URI[archive.sha256sum] = "44694fda6b6233923f5c10a48d02d2cf5724e011a8a85789074c953101f33bf1"
+
+FILES:${PN} += " \
+ ${datadir}/dbus-1 \
+ ${datadir}/metainfo \
+ ${datadir}/gnome-shell \
+"