aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gjs/gjs_1.80.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gjs/gjs_1.80.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.80.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.80.2.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.80.2.bb
new file mode 100644
index 0000000000..1d781d078c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gjs/gjs_1.80.2.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Javascript bindings for GNOME"
+LICENSE = "MIT & LGPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8dcea832f6acf45d856abfeb2d51ec48"
+
+
+DEPENDS = "mozjs-115 cairo"
+
+inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even pkgconfig
+
+SRC_URI[archive.sha256sum] = "135e39c5ac591096233e557cfe577d64093f5054411d47cb2e214bad7d4199bd"
+SRC_URI += " \
+ file://0001-Support-cross-builds-a-bit-better.patch \
+ file://0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch \
+"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+GIR_MESON_OPTION = ""
+
+EXTRA_OEMESON = " \
+ -Dinstalled_tests=false \
+ -Dskip_dbus_tests=true \
+ -Dskip_gtk_tests=true \
+"
+
+LDFLAGS:append:mipsarch = " -latomic"
+LDFLAGS:append:powerpc = " -latomic"
+LDFLAGS:append:powerpc64 = " -latomic"
+LDFLAGS:append:riscv32 = " -latomic"
+
+FILES:${PN} += "${datadir}/gjs-1.0/lsan"
+
+PACKAGES =+ "${PN}-valgrind"
+FILES:${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
+RDEPENDS:${PN}-valgrind += "valgrind"
+
+# Valgrind not yet available on rv32/rv64
+RDEPENDS:${PN}-valgrind:remove:riscv32 = "valgrind"
+RDEPENDS:${PN}-valgrind:remove:riscv64 = "valgrind"