aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/bonobo/libbonobo
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/bonobo/libbonobo')
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch47
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch24
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch26
3 files changed, 0 insertions, 97 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch
deleted file mode 100644
index 44cf1f9fa0..0000000000
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From fef13a371fc91f6d9b42518126c2a8b459fdf0e8 Mon Sep 17 00:00:00 2001
-From: Colin Walters <walters@verbum.org>
-Date: Thu, 2 May 2013 14:17:38 -0400
-Subject: [PATCH] Remove use of G_DISABLE_DEPRECATED
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This now trips up on GStaticRecMutex; I'm not going to bother to port,
-realistically no one is actively maintaining this code anymore.
-
-Upstream-Status: Applied
-
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
----
- activation-server/Makefile.am | 1 -
- configure.in | 2 +-
- 2 files changed, 1 insertions(+), 2 deletions(-)
-
-diff --git a/activation-server/Makefile.am b/activation-server/Makefile.am
-index efb18a8..ffa90f6 100644
---- a/activation-server/Makefile.am
-+++ b/activation-server/Makefile.am
-@@ -17,7 +17,6 @@ INCLUDES= \
- $(SERVER_CFLAGS) \
- $(WARN_CFLAGS) \
- -DSERVER_CONFDIR=\"$(sysconfdir)\" \
-- -DG_DISABLE_DEPRECATED \
- -DG_LOG_DOMAIN=\"Bonobo-Activation-Server\" \
- $(NULL)
-
-diff --git a/configure.in b/configure.in
-index 70a4e26..6be2bca 100644
---- a/configure.in
-+++ b/configure.in
-@@ -132,7 +132,7 @@ AC_SUBST(SERVER_LIBS)
- AC_SUBST(SERVER_CFLAGS)
-
- if test "$enable_maintainer_mode" = "yes"; then
-- DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES"
-+ DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_SINGLE_INCLUDES"
- AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
- fi
-
---
-1.7.6.5
-
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch
deleted file mode 100644
index a20edda841..0000000000
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-| tests/Makefile.am:55: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/te
-st-properties.sh'
-| tests/test-activation/Makefile.am:76: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS
-' (or '*_CPPFLAGS')
-| utils/Makefile.am:9: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS
-')
-| autoreconf: automake failed with exit status: 1
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Not Submitted
-
-Index: libbonobo-2.32.1/tests/Makefile.am
-===================================================================
---- libbonobo-2.32.1.orig/tests/Makefile.am 2010-08-29 04:56:00.000000000 -0700
-+++ libbonobo-2.32.1/tests/Makefile.am 2014-04-25 15:38:22.024744384 -0700
-@@ -55,7 +55,7 @@
- MODELS_DIR="$(srcdir)/models"
-
- TESTS = test-moniker$(EXEEXT) test-event-source$(EXEEXT) test-object$(EXEEXT) \
-- test-stream-mem$(EXEEXT) $(srcdir)/test-properties.sh test-storage-mem$(EXEEXT) \
-+ test-stream-mem$(EXEEXT) test-properties.sh test-storage-mem$(EXEEXT) \
- test-main-loop$(EXEEXT)
-
- # TESTS += test-generic-factory.sh
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch
deleted file mode 100644
index 20db671e05..0000000000
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-This checks whether the format string is a literal on the calling function. As bonobo_debug_print()
-takes already a va_list, we specify the format on the functions that call it
-The second number, which is 0 here, should then be the argument index of the variadic argument
-
-Fixed warning with clang
-
-| ../../libbonobo-2.32.1/bonobo/bonobo-debug.c:58:32: error: format string is not a string literal [-Werror,-Wformat-nonliteral]
-| vfprintf (_bonobo_debug_file, fmt, args);
-| ^~~
-| 1 error generated.
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: libbonobo-2.32.1/bonobo/bonobo-debug.c
-===================================================================
---- libbonobo-2.32.1.orig/bonobo/bonobo-debug.c
-+++ libbonobo-2.32.1/bonobo/bonobo-debug.c
-@@ -47,6 +47,7 @@ bonobo_debug_init(void)
- _bonobo_debug_file = stderr;
- }
-
-+__attribute__((__format__ (printf, 2, 0)))
- void
- bonobo_debug_print (const char *name, char *fmt, ...)
- {