aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl/efl.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/efl/efl.inc')
-rw-r--r--meta-efl/recipes-efl/efl/efl.inc9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc
index ba993af35c..65c9f37fd8 100644
--- a/meta-efl/recipes-efl/efl/efl.inc
+++ b/meta-efl/recipes-efl/efl/efl.inc
@@ -1,6 +1,6 @@
SUMMARY = "EFL"
LICENSE = "MIT & BSD & LGPL-2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=a1809a807e39dd48ddcf7be98477d130"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5cb19adb5be911811c7a4e05152548e8"
DEPENDS_class-native = "freetype-native libxext-native libpng-native jpeg-native tiff-native libfribidi-native glib-2.0-native dbus-native"
DEPENDS = "virtual/libiconv tslib curl glib-2.0 gnutls pkgconfig zlib jpeg openssl libsndfile1 dbus libexif librsvg freetype libpng tiff libxext virtual/libx11 libxdamage libxrender fontconfig libfribidi giflib udev libxcursor libxcomposite libxinerama libxrandr libxtst libxscrnsaver efl-native util-linux"
@@ -33,6 +33,7 @@ EXTRA_OECONF_append_class-native = " \
--disable-physics \
--disable-multisense \
--disable-cserve \
+ --disable-libeeze \
--with-x11=none \
--disable-image-loader-bmp \
--disable-image-loader-eet \
@@ -70,11 +71,6 @@ PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
# currently we don't provide doxygen-native
PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,doxygen-native"
-# new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need
-do_configure_prepend_class-native() {
- sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac
-}
-
do_install_append() {
# don't ship precompiled lua files
rm -f ${datadir}/elua/*/*.luac
@@ -201,6 +197,7 @@ FILES_efreet = " \
"
FILES_eet = " \
${bindir}/eet \
+ ${bindir}/eetpack \
${bindir}/vieet \
${bindir}/diffeet \
${libdir}/libeet${SOLIBS} \