aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch40
-rw-r--r--meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch40
-rw-r--r--meta-oe/recipes-support/fltk/fltk_1.3.4-1.bb (renamed from meta-oe/recipes-support/fltk/fltk_1.3.3.bb)18
3 files changed, 38 insertions, 60 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch b/meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch
deleted file mode 100644
index 014184d533..0000000000
--- a/meta-oe/recipes-support/fltk/fltk/fix-boolean-issue-with-jpeg9.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 14c22398f8370e33a798360ed0dad513af8f1470 Mon Sep 17 00:00:00 2001
-From: AlbrechtS <AlbrechtS@ea41ed52-d2ee-0310-a9c1-e6b18d33e121>
-Date: Sun, 15 Mar 2015 19:32:33 +0000
-Subject: [PATCH] Fix 'boolean' issue with jpeg-9 library compatibility (STR
- #2920).
-
-According to comments in STR #2920 and my own tests this is also
-compatible with older jpeg libraries (at least jpeg-8).
-
-Upstream-Status: Backport
-
----
- src/Fl_JPEG_Image.cxx | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/Fl_JPEG_Image.cxx b/src/Fl_JPEG_Image.cxx
-index 47120a7..6cebe88 100644
---- a/src/Fl_JPEG_Image.cxx
-+++ b/src/Fl_JPEG_Image.cxx
-@@ -155,7 +155,7 @@ Fl_JPEG_Image::Fl_JPEG_Image(const char *filename) // I - File to load
-
- jpeg_create_decompress(&dinfo);
- jpeg_stdio_src(&dinfo, fp);
-- jpeg_read_header(&dinfo, 1);
-+ jpeg_read_header(&dinfo, TRUE);
-
- dinfo.quantize_colors = (boolean)FALSE;
- dinfo.out_color_space = JCS_RGB;
-@@ -337,7 +337,7 @@ Fl_JPEG_Image::Fl_JPEG_Image(const char *name, const unsigned char *data)
-
- jpeg_create_decompress(&dinfo);
- jpeg_mem_src(&dinfo, data);
-- jpeg_read_header(&dinfo, 1);
-+ jpeg_read_header(&dinfo, TRUE);
-
- dinfo.quantize_colors = (boolean)FALSE;
- dinfo.out_color_space = JCS_RGB;
---
-1.7.9.5
-
diff --git a/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch b/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch
index 4d13ffc5d7..2a9915bea7 100644
--- a/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch
+++ b/meta-oe/recipes-support/fltk/fltk/fltk-no-freetype-config.patch
@@ -1,20 +1,40 @@
---- a/configure.in.orig 2015-11-26 14:30:17.893426966 +0800
-+++ b/configure.in 2015-11-26 14:33:00.285424099 +0800
-@@ -969,12 +969,12 @@ case $host_os_gui in
- AC_ARG_ENABLE(xft, [ --enable-xft turn on Xft support [[default=yes]]])
+From 699420d306cadbb5285942e09f4383d84b01985d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Fri, 13 Jan 2017 13:21:23 +0100
+Subject: [PATCH] replace freetype-config by pkg-config
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ configure.ac | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f0efd48..3af5ecb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1006,12 +1006,12 @@ case $host_os_gui in
+ xft_found=no
if test x$enable_xft != xno; then
-- AC_PATH_PROG(FTCONFIG,freetype-config)
-+ AC_PATH_PROG(PKGCONFIG,pkg-config)
+- AC_PATH_PROG(FTCONFIG, freetype-config)
++ AC_PATH_PROG(PKGCONFIG,pkg-config)
- if test "x$FTCONFIG" != x; then
-- CPPFLAGS="`$FTCONFIG --cflags` $CPPFLAGS"
-- CFLAGS="`$FTCONFIG --cflags` $CFLAGS"
-- CXXFLAGS="`$FTCONFIG --cflags` $CXXFLAGS"
+- CPPFLAGS="`$FTCONFIG --cflags` $CPPFLAGS"
+- CFLAGS="`$FTCONFIG --cflags` $CFLAGS"
+- CXXFLAGS="`$FTCONFIG --cflags` $CXXFLAGS"
+ if test "x$PKGCONFIG" != x; then
+ CPPFLAGS="`$PKGCONFIG --cflags xft` $CPPFLAGS"
+ CFLAGS="`$PKGCONFIG --cflags xft` $CFLAGS"
+ CXXFLAGS="`$PKGCONFIG --cflags xft` $CXXFLAGS"
- AC_CHECK_LIB(fontconfig, FcPatternCreate)
+ AC_CHECK_LIB(fontconfig, FcPatternCreate)
AC_CHECK_HEADER(X11/Xft/Xft.h,
+--
+2.7.4
+
diff --git a/meta-oe/recipes-support/fltk/fltk_1.3.3.bb b/meta-oe/recipes-support/fltk/fltk_1.3.4-1.bb
index efba3a9d2d..f08d547900 100644
--- a/meta-oe/recipes-support/fltk/fltk_1.3.3.bb
+++ b/meta-oe/recipes-support/fltk/fltk_1.3.4-1.bb
@@ -6,17 +6,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f6b26344a24a941a01a5b0826e80b5ca"
DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
-SRC_URI = "http://fltk.org/pub/fltk/${PV}/${BP}-source.tar.gz \
- file://disable_test.patch \
- file://fltk-no-freetype-config.patch \
- file://fix-boolean-issue-with-jpeg9.patch \
+SRC_URI = " \
+ http://fltk.org/pub/fltk/1.3.4/${BP}-source.tar.gz \
+ file://disable_test.patch \
+ file://fltk-no-freetype-config.patch \
"
-SRC_URI[md5sum] = "9ccdb0d19dc104b87179bd9fd10822e3"
-SRC_URI[sha256sum] = "f8398d98d7221d40e77bc7b19e761adaf2f1ef8bb0c30eceb7beb4f2273d0d97"
+SRC_URI[md5sum] = "d7fcd27ab928648e1a1366dd2e273970"
+SRC_URI[sha256sum] = "7fb2c8882433ce694e6900c94fda505e8f4ed3fa9c7e597007098a33b85c53f4"
inherit autotools-brokensep binconfig pkgconfig lib_package
+EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
+
TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2"
EXTRA_OECONF = "--enable-shared \
@@ -32,10 +34,6 @@ PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
PACKAGECONFIG[xfixes] = "--enable-xfixes,--disable-xfixes,libxfixes"
PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
-do_configure() {
- oe_runconf
-}
-
do_install_append_class-target() {
sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/fltk-config
}