aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-flexcache_0.3.bb10
-rw-r--r--meta-python/recipes-devtools/python/python3-flexparser_0.3.bb11
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
new file mode 100644
index 0000000000..509a6a42eb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Saves and loads to the cache a transformed versions of a source object."
+HOMEPAGE = "https://github.com/hgrecco/flexcache"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
+DEPENDS += "python3-setuptools-scm-native"
+SRC_URI[sha256sum] = "18743bd5a0621bfe2cf8d519e4c3bfdf57a269c15d1ced3fb4b64e0ff4600656"
+
+inherit pypi python_setuptools_build_meta
+PYPI_PACKAGE = "flexcache"
+RDEPENDS:${PN} = "python3-typing-extensions"
diff --git a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
new file mode 100644
index 0000000000..fb94235f05
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Parsing made fun ... using typing."
+HOMEPAGE = "https://github.com/hgrecco/flexparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
+
+DEPENDS += "python3-setuptools-scm-native"
+SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "flexparser"