aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2019-04-18 11:49:58 -0400
committerKhem Raj <raj.khem@gmail.com>2019-04-27 10:13:06 -0700
commit855be6408dc3e4b7fd5a3cb53c06cda9eefe355d (patch)
tree3313f0a06c87ad5e3940620eb27911762c2931b8 /meta-xfce
parent13615d9593b3793ebd4ceb5ee967f8757bc587cb (diff)
downloadmeta-openembedded-contrib-855be6408dc3e4b7fd5a3cb53c06cda9eefe355d.tar.gz
xfconf: fix 'Failed to get connection to xfconfd' during do_rootfs
Packages such as gdk-pixbuf can result in the following error during the rootfs construction: CRITICAL **: 16:51:57.223: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without X11 $DISPLAY This is hit during the postinst-intercepts/update_pixbuf_cache. Based on discussions upstream: https://bugzilla.xfce.org/show_bug.cgi?id=14789 this appears to be an issue for xfconf and has an upstream update: https://git.xfce.org/xfce/xfconf/commit?id=6f11cc65a2213f424728b5a0d25b1b63c19e773e Drawing from this change we can go ahead and use PACKAGECONFIG to emulate the upstream fix, defaulting to having the gsettings-backend disabled. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfconf/xfconf_4.13.6.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfconf/xfconf_4.13.6.bb b/meta-xfce/recipes-xfce/xfconf/xfconf_4.13.6.bb
index 2667ff947b..ded3c44e5a 100644
--- a/meta-xfce/recipes-xfce/xfconf/xfconf_4.13.6.bb
+++ b/meta-xfce/recipes-xfce/xfconf/xfconf_4.13.6.bb
@@ -16,3 +16,5 @@ FILES_${PN} += "${libdir}/xfce4/xfconf/xfconfd \
${datadir}/dbus-1/services/org.xfce.Xfconf.service"
FILES_${PN}-dev += "${libdir}/gio/modules/libxfconfgsettingsbackend.la"
+
+PACKAGECONFIG[gsettings-backend] = "--enable-gsettings-backend,--disable-gsettings-backend,"