aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFranz Forstmayr <franz.forstmayr@rosenberger.com>2018-05-30 07:40:27 +0200
committerKhem Raj <raj.khem@gmail.com>2018-05-30 09:52:22 -0700
commit2fa700209a9276234c2e91f683054a222c6e2773 (patch)
tree40dee2d27e8c0292d2523c4c8d0bd4c2dbf9ed05 /meta-python
parent068b4ae968ac8984047ed0fb012d6efe32062afd (diff)
downloadmeta-openembedded-contrib-2fa700209a9276234c2e91f683054a222c6e2773.tar.gz
Added python sijax package
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-sijax.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-sijax_0.3.2.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-sijax_0.3.2.bb4
3 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-sijax.inc b/meta-python/recipes-devtools/python/python-sijax.inc
new file mode 100644
index 0000000000..9e46893d85
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sijax.inc
@@ -0,0 +1,8 @@
+DESCRIPTION = "An easy to use AJAX library for Python based on jQuery.ajax"
+HOMEPAGE = "https://github.com/spantaleev/sijax-python"
+LICENSE = "BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=16e213d75641a392478df50cf0841903"
+
+PYPI_PACKAGE = "Sijax"
+inherit pypi \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python-sijax_0.3.2.bb b/meta-python/recipes-devtools/python/python-sijax_0.3.2.bb
new file mode 100644
index 0000000000..4226c42355
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sijax_0.3.2.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "An easy to use AJAX library for Python based on jQuery.ajax"
+HOMEPAGE = "https://github.com/spantaleev/sijax-python"
+LICENSE = "BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=16e213d75641a392478df50cf0841903"
+
+PYPI_PACKAGE = "Sijax"
+inherit setuptools
+require python-sijax.inc
+
+SRC_URI[sha256sum] = "11b062f4a8b2aad95c87e7c09e5daf5a6b0d0f08abf9efe5f91a0075c6be7c0d" \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-sijax_0.3.2.bb b/meta-python/recipes-devtools/python/python3-sijax_0.3.2.bb
new file mode 100644
index 0000000000..24e683372e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sijax_0.3.2.bb
@@ -0,0 +1,4 @@
+inherit setuptools3
+require python-sijax.inc
+
+SRC_URI[sha256sum] = "11b062f4a8b2aad95c87e7c09e5daf5a6b0d0f08abf9efe5f91a0075c6be7c0d" \ No newline at end of file