aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2016-12-01 13:24:47 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-09 12:02:18 +0100
commit1b73d2c713938f10931749ece3a703ad9004376a (patch)
treeecec419fa138d851cc4727ab6abdd46c67fd41f5 /meta-python
parentd356e03ced0873a0fe1a7a69cb05ee803e363888 (diff)
downloadmeta-openembedded-contrib-1b73d2c713938f10931749ece3a703ad9004376a.tar.gz
python-wrapt: add new recipe
The recipe defines the wrapt python module. This module provides a transparent object proxy for Python that can be used in the construction of function wrappers and decorators. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-wrapt_1.10.8.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-wrapt_1.10.8.bb b/meta-python/recipes-devtools/python/python-wrapt_1.10.8.bb
new file mode 100644
index 0000000000..cf92efa4af
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-wrapt_1.10.8.bb
@@ -0,0 +1,10 @@
+SUMMARY = "A Python module for decorators, wrappers and monkey patching."
+HOMEPAGE = "http://wrapt.readthedocs.org/"
+LICENSE = "BSD"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=82704725592991ea88b042d150a66303"
+
+SRC_URI[md5sum] = "7c2a7e6262acc396ef6528b3d66bd047"
+SRC_URI[sha256sum] = "4ea17e814e39883c6cf1bb9b0835d316b2f69f0f0882ffe7dad1ede66ba82c73"
+
+inherit setuptools pypi