aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorParthiban Nallathambi <parthitce@gmail.com>2019-05-01 18:40:15 +0200
committerKhem Raj <raj.khem@gmail.com>2019-05-03 10:04:45 -0700
commitfbc9a4134136c183535ad0b35d9a3c53a8dd2f8a (patch)
tree5f84184a9e2ff789795c1609c5c2d7decf419c1f /meta-python
parentceda4b3ac56d7a3ddc27b0d5dda3ba27c9c6f17a (diff)
downloadmeta-openembedded-contrib-fbc9a4134136c183535ad0b35d9a3c53a8dd2f8a.tar.gz
python3-tinyrecord: add version 0.1.5
Signed-off-by: Parthiban Nallathambi <parthitce@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-tinyrecord.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-tinyrecord_0.1.5.bb2
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-tinyrecord.inc b/meta-python/recipes-devtools/python/python-tinyrecord.inc
new file mode 100644
index 0000000000..981dc074fc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tinyrecord.inc
@@ -0,0 +1,15 @@
+SUMMARY = "transaction support for TinyDB"
+DESCRIPTION = "\
+Tinyrecord is a library which implements atomic transaction \
+support for the TinyDB NoSQL database. It uses a record-first \
+then execute architecture which allows us to minimize the time \
+that we are within a thread lock."
+HOMEPAGE = "https://github.com/eugene-eeo/tinyrecord"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README;md5=31c1dc11b4ae83546538de4c16bceabc"
+
+SRC_URI[md5sum] = "e47dcfe299686cd3fa7ffaa7cb2ee8b1"
+SRC_URI[sha256sum] = "bc7e6a8e78600df234d7a85c2f5d584130f2c6ffd7cd310f9d3a1d976d3373c8"
+
+PYPI_PACKAGE = "tinyrecord"
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-tinyrecord_0.1.5.bb b/meta-python/recipes-devtools/python/python3-tinyrecord_0.1.5.bb
new file mode 100644
index 0000000000..3f1b31f48b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tinyrecord_0.1.5.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-tinyrecord.inc