aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-23 12:20:13 +0800
committerKhem Raj <raj.khem@gmail.com>2023-03-22 22:01:40 -0700
commit40f53a3a1f3fc19aa18840f7fd5f61dbeb3a1ff5 (patch)
tree1386a3dc77eea9e9236b45feea04c774ee4dd00d /meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
parentdd9119512956d96a38edc4b62857cc8dc202e516 (diff)
downloadmeta-openembedded-contrib-40f53a3a1f3fc19aa18840f7fd5f61dbeb3a1ff5.tar.gz
python3-daemon: upgrade 2.3.2 -> 3.0.1
Changelog: ========== Bugs Fixed: * Migrate to use the explicitly-maintained 'packaging' library. The package bundled in 'setuptools.extern.packaging' is to help make that package self-contained, but is not a supported API. * Declare dependency on Setuptools >= 62.4.0. This is necessary for establishing the version information via Setuptools. We use 'setuptools.command.build', 'introduced in Setuptools version 62.4.0 * Refactor calculation of file descriptor ranges to close. Added: * Document a 'ServiceRunner' class as an example of using 'DaemonContext'. * PyPA recommended Project URLs for the distribution. Changed: * Raise a TypeError if any 'exclude' values are not valid file descriptors. * Migrate package version handling to use Setuptools API. Removed: * Remove redundant 'wheel' from the requirements specification. * Remove Setuptools 'test' command support. * Remove Setuptools 'register' and 'upload' command support. * Remove the obsolete 'runner' module. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb b/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
new file mode 100644
index 0000000000..79507bdce2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Library to implement a well-behaved Unix daemon process"
+HOMEPAGE = "https://pagure.io/python-daemon/"
+SECTION = "devel/python"
+
+DEPENDS += "${PYTHON_PN}-docutils-native"
+RDEPENDS:${PN} = "${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-lockfile (>= 0.10) \
+ ${PYTHON_PN}-resource \
+"
+
+LICENSE = "Apache-2.0 & GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://README;md5=a3a94c615dc969a70525f1eebbacf235"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "6c57452372f7eaff40934a1c03ad1826bf5e793558e87fef49131e6464b4dae5"
+
+PYPI_PACKAGE = "python-daemon"