aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-28 15:21:05 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:51 -0700
commit0a83476cac91ee1ea19f4e220bb986b5e111751f (patch)
tree1628d5e8ae48a70747bea159fe0a676059d5326f /meta-perl
parente427280262dad491f68d6e183e0d57fd9ca87446 (diff)
downloadmeta-openembedded-contrib-0a83476cac91ee1ea19f4e220bb986b5e111751f.tar.gz
libcrypt-openssl-guess: Add recipe
Add recipe for CPAN hosted Perl5 module Crypt::OpenSSL::Guess version 0.11 as prerequisite for libcrypt-openssl-rsa-perl update to express our love for the Perl Programming Language. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb
new file mode 100644
index 0000000000..21be047206
--- /dev/null
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Guess OpenSSL include path"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea914cc2718e8d53bd7744d96e66c03c"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Guess-${PV}.tar.gz "
+
+SRC_URI[md5sum] = "e768fe2c07826b0ac9ea604c79f93032"
+SRC_URI[sha256sum] = "aa6b18e38cb852cbad80a58cd90c395b40819d4d01e0ab37e7703149094d7167"
+
+DEPENDS += "openssl"
+
+RDEPENDS_${PN}="perl-module-config perl-module-exporter perl-module-symbol perl-module-file-spec"
+
+EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
+
+S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND = "native"