aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-08-27 12:16:11 +0800
committerKhem Raj <raj.khem@gmail.com>2018-08-27 10:53:58 -0700
commita24b4c1bbead01a94d8ac26adb4657c29592cb52 (patch)
tree8c86d1b2f1664db21009c3a47edf2f2b3a20c886 /meta-oe
parenteac9bd96cefbddb131ee5ec30a02c08749fbb6ca (diff)
downloadmeta-openembedded-contrib-a24b4c1bbead01a94d8ac26adb4657c29592cb52.tar.gz
lmbench: fix usrmerge install path
Rework the patch use-base_libdir-instead-of-hardcoded-lib.patch to 0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch to fix the below do_install error when usrmerge enabled in DISTRO_FEATURES and also fix the lib name from lmbench.a to libmbench.a | if [ ! -d /poky-build/tmp-glibc/work/core2-64-wrs-linux/lmbench/3.0-a9-r2/image/usr/usr/lib64 ]; then mkdir /poky-build/tmp-glibc/work/core2-64-wrs-linux/lmbench/3.0-a9-r2/image/usr/usr/lib64; fi | mkdir: cannot create directory /poky-build/tmp-glibc/work/core2-64-wrs-linux/lmbench/3.0-a9-r2/image/usr/usr/lib64 No such file or directory | Makefile:141: recipe for target 'install-target' failed | make[1]: *** [install-target] Error 1 Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch (renamed from meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch)24
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb3
2 files changed, 16 insertions, 11 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch
index c6e9465ac3..04cef960fc 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch
@@ -1,30 +1,34 @@
-From 73fdc58ca4eb9e2f24d854b3af3a4e5daac5a33e Mon Sep 17 00:00:00 2001
-From: Ting Liu <b28495@freescale.com>
-Date: Fri, 22 Nov 2013 15:20:08 +0800
-Subject: [PATCH] use base_libdir instead of hardcoded /lib
+From ea683a0dbaa30a0bf101adb09a1a2531c7112c62 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <Mingli.Yu@windriver.com>
+Date: Mon, 27 Aug 2018 11:02:45 +0800
+Subject: [PATCH] src/Makefile: use libdir instead of hardcoded /lib
-Upstream Status: Inappropriate [configuration]
+use libdir instead of hardcoded /lib
-Signed-off-by: Ting Liu <b28495@freescale.com>
+Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
---
src/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/Makefile b/src/Makefile
-index c7a8c79..c7e4e3c 100644
+index 4678d54..b73ddb6 100644
--- a/src/Makefile
+++ b/src/Makefile
-@@ -143,10 +143,10 @@ install-target:
+@@ -141,10 +141,10 @@ install-target:
if [ ! -d $(BASE) ]; then mkdir $(BASE); fi
if [ ! -d $(BASE)/bin ]; then mkdir $(BASE)/bin; fi
if [ ! -d $(BASE)/include ]; then mkdir $(BASE)/include; fi
- if [ ! -d $(BASE)/lib ]; then mkdir $(BASE)/lib; fi
-+ if [ ! -d $(BASE)$(base_libdir) ]; then mkdir $(BASE)$(base_libdir); fi
++ if [ ! -d $(DESTDIR)$(libdir) ]; then mkdir $(DESTDIR)$(libdir); fi
cp $(EXES) $(BASE)/bin
cp $(INCS) $(BASE)/include
- cp $O/lmbench.a $(BASE)/lib/libmbench.a
-+ cp $O/lmbench.a $(BASE)$(base_libdir)
++ cp $O/lmbench.a $(DESTDIR)$(libdir)/libmbench.a
cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install
+--
+2.7.4
+
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index 593b62f013..8e6e803a8d 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -19,13 +19,13 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://update-results-script.patch \
file://obey-ranlib.patch \
file://update-config-script.patch \
- file://use-base_libdir-instead-of-hardcoded-lib.patch \
file://lmbench_result_html_report.patch \
file://fix-lmbench-memory-check-failure.patch \
file://0001-avoid-gcc-optimize-away-the-loops.patch \
file://0001-lat_http.c-Add-printf-format.patch \
file://0001-Check-for-musl-define-guard-before-redefining-sockle.patch \
file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \
+ file://0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch \
"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -66,6 +66,7 @@ do_install () {
fi
oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \
+ DESTDIR="${D}" \
-C src install
mv ${D}${bindir}/line ${D}${bindir}/lm_line
install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/