aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-06 11:50:16 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 10:46:29 -0700
commit973578148d343222e8a6a89076f515a4094a7844 (patch)
treed2c48d8a909271ddb226bc7b1c19a451321c4204 /meta-oe
parent5cb9dae677066a0367a3eeef1953814d0c1fb6ca (diff)
downloadmeta-openembedded-contrib-973578148d343222e8a6a89076f515a4094a7844.tar.gz
uftrace: Upgrade to 0.8.3
* Deliberately provide a non existing path to with_elfutils so it does not copy libelf.so into its staged install and become a provider for that library while elfutils should be the legit provider and this package should just list it in its rdeps * Fix build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch39
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb (renamed from meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb)12
2 files changed, 47 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch
new file mode 100644
index 0000000000..fe7aac9318
--- /dev/null
+++ b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch
@@ -0,0 +1,39 @@
+From cdf7f2e394fcfb93a61f509ae3388f29540a6b35 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 8 Sep 2018 11:56:13 -0700
+Subject: [PATCH] include dlfcn.h for RTLD_DEFAULT
+
+Fixes
+plthook.c:128:41: error: use of undeclared identifier 'RTLD_DEFAULT'
+
+Upstream-Status: Submitted [https://github.com/namhyung/uftrace/pull/487]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ libmcount/plthook.c | 1 +
+ utils/debug.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/libmcount/plthook.c b/libmcount/plthook.c
+index d9d84f0..d54f5e8 100644
+--- a/libmcount/plthook.c
++++ b/libmcount/plthook.c
+@@ -6,6 +6,7 @@
+ #include <sys/mman.h>
+ #include <pthread.h>
+ #include <assert.h>
++#include <dlfcn.h>
+
+ /* This should be defined before #include "utils.h" */
+ #define PR_FMT "mcount"
+diff --git a/utils/debug.c b/utils/debug.c
+index 2134b09..5460def 100644
+--- a/utils/debug.c
++++ b/utils/debug.c
+@@ -13,6 +13,7 @@
+ #include <assert.h>
+ #include <limits.h>
+ #include <inttypes.h>
++#include <dlfcn.h>
+
+ #include "utils/utils.h"
+
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
index 82b179521c..e377a5c9d5 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
@@ -10,15 +10,19 @@ DEPENDS_append_libc-musl = " argp-standalone"
inherit autotools
-SRCREV = "5af9ff9fa89c340617e52c8ed05798b352a7145c"
-SRC_URI = "git://github.com/namhyung/${BPN}"
+# v0.8.3
+SRCREV = "8b723a6fae2ef30495cd6279774fba9c95cd9c88"
+SRC_URI = "git://github.com/namhyung/${BPN} \
+ file://0001-include-dlfcn.h-for-RTLD_DEFAULT.patch \
+ "
S = "${WORKDIR}/git"
LDFLAGS_append_libc-musl = " -largp"
-EXTRA_OECONF = "ARCH=${TARGET_ARCH}"
+EXTRA_UFTRACE_OECONF = "ARCH=${TARGET_ARCH} \
+ with_elfutils=/use/libelf/from/sysroot"
do_configure() {
- ${S}/configure ${EXTRA_OECONF}
+ ${S}/configure ${EXTRA_UFTRACE_OECONF}
}
FILES_SOLIBSDEV = ""