aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2019-01-25 14:05:16 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-26 11:00:07 -0800
commit7c52d8ab718871858caa499b5cf769c9b7c19454 (patch)
treef9840183da81095ae9c7fcb2b13f1db152746358 /meta-oe
parent3593ada34854b666c676409e56463d66f0c3d208 (diff)
downloadmeta-openembedded-contrib-7c52d8ab718871858caa499b5cf769c9b7c19454.tar.gz
libkcapi: Fix missing bash (for apps) and unneeded checksums (for testapp) when building
Fix build failures: 1. with "apps" PACKAGECONFIG: ERROR: libkcapi-1.1.3+gitAUTOINC+1c736c43eb-r0 do_package: QA Issue: libkcapi: Files/directories were installed but not shipped in any package: /usr/bin/.sha1hmac.hmac /usr/lib/.libkcapi.so.1.1.3.hmac 2. with "testapp" PACKAGECONFIG: ERROR: libkcapi-1.1.3+gitAUTOINC+1c736c43eb-r0 do_package_qa: QA Issue: /usr/libexec/libkcapi/test.sh contained in package libkcapi requires /bin/bash, but no providers found in RDEPENDS_libkcapi? [file-rdeps] Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb b/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
index a93ddc8237..f70f774bf2 100644
--- a/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
+++ b/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
@@ -16,13 +16,17 @@ SRC_URI = " \
inherit autotools
PACKAGECONFIG ??= ""
-PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,"
+PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
do_install_append() {
# bindir contains testapp and apps. However it is always created, even
# when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
rmdir --ignore-fail-on-non-empty ${D}${bindir}
+
+ # Remove the generated binary checksum files
+ rm -f ${D}${bindir}/.*.hmac
+ rm -f ${D}${libdir}/.*.hmac
}
CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"