aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAlistair Francis <alistair23@gmail.com>2019-02-07 22:07:58 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-08 15:17:32 -0800
commit5b5fae3a07a00e95e53f4bda7b41bc8348d639e0 (patch)
treedb00e9f54709589d415ea1a7b803f9f5af6d8c06 /meta-oe
parente0fe1b0477734b653711741ed59f6f60c3aaa99e (diff)
downloadmeta-openembedded-contrib-5b5fae3a07a00e95e53f4bda7b41bc8348d639e0.tar.gz
vncx11: Fix dev package do_rootfs failure
When building the dev package I see these errors: Collected errors: * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbproto.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfb.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbregion.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbconfig.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/keysym.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbclient.h But that file is already provided by package * libvncserver-dev as both libvncserver and x11vnx try to install the same files let's just remove them from x11vnc. Signed-off-by: Alistair Francis <alistair@alistair23.me> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
index b047bc4628..774d2c9cb6 100644
--- a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
+++ b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
@@ -32,3 +32,7 @@ do_prepare_sources () {
sed -i -e '/^# libtool.m4/q' ${S}/acinclude.m4
}
do_patch[postfuncs] += "do_prepare_sources"
+
+do_install_append() {
+ rm -rf ${D}/usr/include/rfb
+}