aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2018-08-18 15:26:59 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit3ceefec415df8acca98460c4ed91a5fa6510c1b9 (patch)
tree8f4ff0ff2115822b4a7bc8602333563af73e0c49 /meta-oe
parent0d614c4220d29da14eba7fccbb21fa6b53d63fec (diff)
downloadmeta-openembedded-contrib-3ceefec415df8acca98460c4ed91a5fa6510c1b9.tar.gz
cpprest: bump version to 2.10.5, refresh patches
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch25
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch59
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.5/747.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.3/747.patch)1
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.5/845.patch42
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-float-tests.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-float-tests.patch)0
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-outside-tests.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch)0
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-test-timeouts.patch (renamed from meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-test-timeouts.patch)0
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest_2.10.5.bb (renamed from meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb)7
8 files changed, 46 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch
deleted file mode 100644
index 9fcffbfed2..0000000000
--- a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/732.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 3d8caad3f459d8b2136c5bc9be7fdec53e5d777d Mon Sep 17 00:00:00 2001
-From: Wu Yongwei <wuyongwei@gmail.com>
-Date: Tue, 10 Apr 2018 11:29:12 +0800
-Subject: [PATCH] Fix a build problem on Clang.
-
-AND_CAPTURE_MEMBER_FUNCTION_POINTERS workaround had a check for GCC,
-but did not exclude Clang. Clang has a fake GCC version of 4.2, thus
-caused problems.
----
- Release/src/http/client/http_client_asio.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Release/src/http/client/http_client_asio.cpp b/Release/src/http/client/http_client_asio.cpp
-index 4ba3e085..fca4bb5b 100644
---- a/Release/src/http/client/http_client_asio.cpp
-+++ b/Release/src/http/client/http_client_asio.cpp
-@@ -47,7 +47,7 @@
- #include <unordered_set>
- #include <memory>
-
--#if defined(__GNUC__)
-+#if defined(__GNUC__) && !defined(__clang__)
-
- #if __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 8)
- #define AND_CAPTURE_MEMBER_FUNCTION_POINTERS
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch
deleted file mode 100644
index 4d03e6d282..0000000000
--- a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Description: install cmake files into /usr/lib/cmake/cpprestsdk
-Author: Gianfranco Costamagna <locutusofborg@debian.org>
-Upstream-Status: https://github.com/Microsoft/cpprestsdk/pull/737
-Forwarded: https://github.com/Microsoft/cpprestsdk/pull/737
-Last-Update: 2018-04-19
-
-Index: cpprest/Release/CMakeLists.txt
-===================================================================
---- cpprest.orig/Release/CMakeLists.txt
-+++ cpprest/Release/CMakeLists.txt
-@@ -18,7 +18,6 @@
- set(WERROR ON CACHE BOOL "Treat Warnings as Errors.")
- set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.")
- set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.")
--set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.")
- set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.")
- set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.")
-
-@@ -63,6 +62,9 @@
- include(cmake/cpprest_find_openssl.cmake)
- include(cmake/cpprest_find_websocketpp.cmake)
- include(CheckIncludeFiles)
-+if(UNIX)
-+include(GNUInstallDirs)
-+endif(UNIX)
-
- find_package(Threads REQUIRED)
- if(THREADS_HAVE_PTHREAD_ARG)
-Index: cpprest/Release/src/CMakeLists.txt
-===================================================================
---- cpprest.orig/Release/src/CMakeLists.txt
-+++ cpprest/Release/src/CMakeLists.txt
-@@ -253,21 +253,21 @@
- install(
- TARGETS ${CPPREST_TARGETS}
- EXPORT cpprestsdk-targets
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- )
-
- configure_file(../cmake/cpprestsdk-config.in.cmake "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake" @ONLY)
-
- install(
- FILES "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake"
-- DESTINATION ${CPPREST_EXPORT_DIR}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
- )
- install(
- EXPORT cpprestsdk-targets
- FILE cpprestsdk-targets.cmake
- NAMESPACE cpprestsdk::
-- DESTINATION ${CPPREST_EXPORT_DIR}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
- )
- endif()
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/747.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/747.patch
index 94bb005989..81a76ea9fc 100644
--- a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/747.patch
+++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/747.patch
@@ -1,4 +1,5 @@
Description: fix for upstream issue 747, clang 6 build error
+Forwarded: https://github.com/Microsoft/cpprestsdk/pull/844
From: rozhuk-im
--- a/Release/include/pplx/pplxlinux.h 2018-04-29 16:22:39.927675000 +0300
+++ b/Release/include/pplx/pplxlinux.h 2018-04-29 16:22:57.809537000 +0300
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.5/845.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/845.patch
new file mode 100644
index 0000000000..8a349aef78
--- /dev/null
+++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/845.patch
@@ -0,0 +1,42 @@
+From c4a09f3d29a57022e03e2849f04c111a57a6a388 Mon Sep 17 00:00:00 2001
+From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Date: Sat, 18 Aug 2018 14:59:38 +0200
+Subject: [PATCH] Fix default installation path
+
+---
+ Release/CMakeLists.txt | 2 +-
+ Release/src/CMakeLists.txt | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Release/CMakeLists.txt b/Release/CMakeLists.txt
+index c93d3cc49..d20b4b070 100644
+--- a/Release/CMakeLists.txt
++++ b/Release/CMakeLists.txt
+@@ -18,7 +18,7 @@ enable_testing()
+ set(WERROR ON CACHE BOOL "Treat Warnings as Errors.")
+ set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.")
+ set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.")
+-set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.")
++set(CPPREST_EXPORT_DIR cmake CACHE STRING "Directory to install CMake config files.")
+ set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.")
+ set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.")
+
+diff --git a/Release/src/CMakeLists.txt b/Release/src/CMakeLists.txt
+index a34605bda..050ff71fc 100644
+--- a/Release/src/CMakeLists.txt
++++ b/Release/src/CMakeLists.txt
+@@ -262,12 +262,12 @@ if(CPPREST_INSTALL)
+
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake"
+- DESTINATION ${CPPREST_EXPORT_DIR}
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPPREST_EXPORT_DIR}
+ )
+ install(
+ EXPORT cpprestsdk-targets
+ FILE cpprestsdk-targets.cmake
+ NAMESPACE cpprestsdk::
+- DESTINATION ${CPPREST_EXPORT_DIR}
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPPREST_EXPORT_DIR}
+ )
+ endif()
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-float-tests.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-float-tests.patch
index 75f74ec658..75f74ec658 100644
--- a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-float-tests.patch
+++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-float-tests.patch
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-outside-tests.patch
index b9b3591c3a..b9b3591c3a 100644
--- a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch
+++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-outside-tests.patch
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-test-timeouts.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-test-timeouts.patch
index 93c3e8a269..93c3e8a269 100644
--- a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-test-timeouts.patch
+++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.5/disable-test-timeouts.patch
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.5.bb
index addacbbd25..040c43ff0e 100644
--- a/meta-oe/recipes-support/cpprest/cpprest_2.10.3.bb
+++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.5.bb
@@ -9,13 +9,12 @@ SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=maste
file://disable-outside-tests.patch \
file://disable-test-timeouts.patch \
file://disable-float-tests.patch \
- file://fix-cmake-install.patch \
file://747.patch \
- file://732.patch \
+ file://845.patch \
"
-# tag 2.10.3
-SRCREV= "e388a2e523f4d0b6aee2bb923637d82d8b969556"
+# tag 2.10.5
+SRCREV= "25d6b26f7038eeec3b51e2e0a70960a8e34fcd68"
S = "${WORKDIR}/git"