aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorchunguang yang <chunguang.yang@windriver.com>2017-01-05 04:44:26 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-25 15:58:51 +0100
commit0de62aa856643d72320142e37f4cceb8397881b5 (patch)
tree3c77043ea988c0e36dae1bdd67024f094dff05ab /meta-oe
parentdef2483db69afdf8799b86ac0234a9ba52e8debf (diff)
downloadmeta-openembedded-contrib-0de62aa856643d72320142e37f4cceb8397881b5.tar.gz
lcov: fix env command argument pass issue
when exec lcov in bash, the following error will appear: /usr/bin/env: 'perl -w': No such file or directory perl uses the -w option to enable many warnings. But the env command can't pass the argument to perl, instead it treate perl -w as a file. To fix this issue, just keep the origin perl path and not use env command. Signed-off-by: chunguang yang <chunguang.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/lcov/lcov_1.11.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/lcov/lcov_1.11.bb b/meta-oe/recipes-support/lcov/lcov_1.11.bb
index 114bd84cdd..2f9ac336e9 100644
--- a/meta-oe/recipes-support/lcov/lcov_1.11.bb
+++ b/meta-oe/recipes-support/lcov/lcov_1.11.bb
@@ -23,6 +23,5 @@ SRC_URI[sha256sum] = "c282de8d678ecbfda32ce4b5c85fc02f77c2a39a062f068bd8e774d29d
do_install() {
oe_runmake install PREFIX=${D}
- sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/*
}