aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-05-06 10:29:43 +0200
committerKhem Raj <raj.khem@gmail.com>2019-05-06 08:32:04 -0700
commit833d94b9b49e15694b0765159d80d6872b6e3976 (patch)
tree516723574cee83b44624143c8646244bbb1e8bcd /meta-oe
parent15ec594e1598645a09a0e6be1cd43576b29c661c (diff)
downloadmeta-openembedded-contrib-833d94b9b49e15694b0765159d80d6872b6e3976.tar.gz
itstool: rework - it went out too early
* adjust dependencies * adjust shebang correctly - caused errors not easy to debug in dependent packages Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/itstool/itstool_2.0.5.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/itstool/itstool_2.0.5.bb b/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
index b74d5f6078..166e95b3aa 100644
--- a/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
+++ b/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5"
inherit autotools python3native
-DEPENDS = "python3-native python3-lxml-native"
+DEPENDS = "python3-lxml-native"
SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2"
SRC_URI[md5sum] = "655c6f78fc64faee45adcc45ccc5a57e"
@@ -13,10 +13,10 @@ SRC_URI[sha256sum] = "100506f8df62cca6225ec3e631a8237e9c04650c77495af4919ac6a100
do_install_append() {
# fix shebang of main script
- sed -i 's:${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}:${bindir}/${PYTHON_PN}:g' ${D}${bindir}/itstool
+ sed -i 's:^#!${WORKDIR}.*${PYTHON_PN} -s:#!${bindir_native}/${PYTHON_PN} -s:' ${D}${bindir}/itstool
}
BBCLASSEXTEND = "native"
-RDEPENDS_${PN} += "python3 python3-lxml"
+RDEPENDS_${PN} += "python3-lxml"