aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-03-27 16:35:02 +0100
committerKhem Raj <raj.khem@gmail.com>2019-03-28 11:55:34 -0700
commit1e1a4e4e68949c210e8591b18721627e6f78609b (patch)
tree86e63cc7e65afa1154a543eb1e609317458fb69c /meta-oe/recipes-support
parentaf8b3722ef89327a01683a6c9010da2cc2c57098 (diff)
downloadmeta-openembedded-contrib-1e1a4e4e68949c210e8591b18721627e6f78609b.tar.gz
itstool: initial add 2.0.5
It lived in meta-qt5-extra for a while (don't remember why - it was not used) but now we need it for upcoming gnome upgrades. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/itstool/itstool_2.0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/itstool/itstool_2.0.5.bb b/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
new file mode 100644
index 0000000000..b74d5f6078
--- /dev/null
+++ b/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "ITS Tool allows you to translate your XML documents with PO files"
+HOMEPAGE = "http://itstool.org/"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5"
+
+inherit autotools python3native
+
+DEPENDS = "python3-native python3-lxml-native"
+
+SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2"
+SRC_URI[md5sum] = "655c6f78fc64faee45adcc45ccc5a57e"
+SRC_URI[sha256sum] = "100506f8df62cca6225ec3e631a8237e9c04650c77495af4919ac6a100d4b308"
+
+do_install_append() {
+ # fix shebang of main script
+ sed -i 's:${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}:${bindir}/${PYTHON_PN}:g' ${D}${bindir}/itstool
+}
+
+BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} += "python3 python3-lxml"
+