aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-19 18:18:55 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-20 19:09:06 -0700
commit290ad988fb94ccde70dcfcba573d162a5c56c339 (patch)
treec821a5f79dca4a9e286a69af004cddd44b293eb2 /meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
parente6b7da8d871239f95df31d8572c3244206d3e1d1 (diff)
downloadmeta-openembedded-contrib-290ad988fb94ccde70dcfcba573d162a5c56c339.tar.gz
uim: Update to 1.8.8
License-Update: Change URI from code.google.com to github.com [1] Drop the patches they seem to be not needed Add dependency on libedit Disable parallel make due to races aarch64 support is upstream so drop the patch [1] https://github.com/uim/uim/commit/a1cf71ec3719389874c42dd4c719a15509983485#diff-7116ef0705885343c9e1b2171a06be0e Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch')
-rw-r--r--meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch24
1 files changed, 11 insertions, 13 deletions
diff --git a/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch b/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
index 0c8f02d6ce..510a8c8407 100644
--- a/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
+++ b/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
@@ -9,18 +9,16 @@ Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 9be879c..9249bfd 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1208,8 +1208,8 @@ AC_HELP_STRING([--with-libedit[=DIR], Enable libedit support
- if test "x$use_libedit" != "xno"; then
- saved_CPPFLAGS=$CPPFLAGS
- saved_LDFLAGS=$LDFLAGS
-- CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
-- LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
-+ CPPFLAGS="${CPPFLAGS} "
-+ LDFLAGS="${LDFLAGS} "
- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
+@@ -1317,8 +1317,8 @@ if test "x$with_libedit" != xno; then
+
+ saved_CPPFLAGS=$CPPFLAGS
+ saved_LDFLAGS=$LDFLAGS
+- CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
+- LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
++ CPPFLAGS="${CPPFLAGS}"
++ LDFLAGS="${LDFLAGS}"
+ AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
+ [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
+ AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")