aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv/opencv_2.4.bb
diff options
context:
space:
mode:
authormike.looijmans@topic.nl <mike.looijmans@topic.nl>2015-03-05 11:24:25 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-06 07:33:25 +0100
commitaa030ae90fb8fadcff320f5d7c751ccb4fdd82bf (patch)
treeb62bd177245bc2f882ee93c5a32a07ef655f6558 /meta-oe/recipes-support/opencv/opencv_2.4.bb
parentf67d6c8b121554b4a323a2d354cd60e302d28cd9 (diff)
downloadmeta-openembedded-contrib-aa030ae90fb8fadcff320f5d7c751ccb4fdd82bf.tar.gz
opencv: Upgrade to 2.4.11
Upgrade OpenCV to the 2.4.11 release. Remove the opencv-fix-pkgconfig-generation patch which has been integrated upstream, be it in modified form. Disable 1394 support by default to get a deterministic build. Fix "jasper" dependency, the BUILD_JASPER parameter served only to build an internal library, while WITH_JASPER actually controls whether jpeg2000 support was desired. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv/opencv_2.4.bb')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index 63d7c8b25b..27546161d2 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -9,12 +9,10 @@ ARM_INSTRUCTION_SET = "arm"
DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0"
-SRCREV = "df8e28283f09825cca0c2902160b7abebcfe1b64"
-SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \
- file://opencv-fix-pkgconfig-generation.patch \
-"
+SRCREV = "2c9547e3147779001811d01936aed38f560929fc"
+SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4"
-PV = "2.4.9+git${SRCPV}"
+PV = "2.4.11+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -25,6 +23,7 @@ OECMAKE_BUILDPATH = "${WORKDIR}/build-${TARGET_ARCH}"
EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \
-DBUILD_PYTHON_SUPPORT=ON \
-DWITH_GSTREAMER=OFF \
+ -DWITH_1394=OFF \
-DCMAKE_SKIP_RPATH=ON \
${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \
${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
@@ -40,7 +39,7 @@ PACKAGECONFIG[libav] = "-DWITH_FFMPEG=ON,-DWITH_FFMPEG=OFF,libav,"
PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng,"
PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff,"
PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
-PACKAGECONFIG[jasper] = "-DBUILD_JASPER=ON,-DBUILD_JASPER=OFF,jasper"
+PACKAGECONFIG[jasper] = "-DWITH_JASPER=ON,-DWITH_JASPER=OFF,jasper,"
inherit distutils-base pkgconfig cmake