aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog/glog/libexecinfo.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-02 10:18:42 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-02 21:42:59 -0700
commitf3c21a3fe2f1026acb67cd0f904acb5a911eb7b2 (patch)
treed928919f58595d2bfa6254341050dd693713a315 /meta-oe/recipes-support/glog/glog/libexecinfo.patch
parent06d27606e8b7125396d333212a8dd04a529bbaa8 (diff)
downloadmeta-openembedded-contrib-f3c21a3fe2f1026acb67cd0f904acb5a911eb7b2.tar.gz
glog: Upgrade to 0.5.0
Libunwind is being detected now via cmake correctly Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/glog/glog/libexecinfo.patch')
-rw-r--r--meta-oe/recipes-support/glog/glog/libexecinfo.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/glog/glog/libexecinfo.patch b/meta-oe/recipes-support/glog/glog/libexecinfo.patch
index ae46d3274f..927c269a6a 100644
--- a/meta-oe/recipes-support/glog/glog/libexecinfo.patch
+++ b/meta-oe/recipes-support/glog/glog/libexecinfo.patch
@@ -8,17 +8,17 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -115,6 +115,7 @@ check_cxx_compiler_flag (-Wunnamed-type-
- check_symbol_exists (snprintf stdio.h HAVE_SNPRINTF)
+@@ -144,6 +144,7 @@ check_cxx_compiler_flag (-Wunnamed-type-
+ check_symbol_exists (snprintf cstdio HAVE_SNPRINTF)
check_library_exists (dbghelp UnDecorateSymbolName "" HAVE_DBGHELP)
+check_library_exists (execinfo backtrace "" HAVE_EXECINFO)
- find_package(Libunwind)
-
-@@ -471,6 +472,10 @@ if (Libunwind_FOUND)
- target_link_libraries (glog PUBLIC unwind)
- endif (Libunwind_FOUND)
+ check_cxx_source_compiles ("
+ #include <cstdlib>
+@@ -584,6 +585,10 @@ if (Unwind_FOUND)
+ set (Unwind_DEPENDENCY "find_dependency (Unwind ${Unwind_VERSION})")
+ endif (Unwind_FOUND)
+if (HAVE_EXECINFO)
+ target_link_libraries (glog PUBLIC execinfo)