aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-29 16:37:15 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-06 13:00:09 +0200
commitbc4d1aa833f62e1bc270eaed99dfd50c0f7abe3a (patch)
treeeb6e580b21c3a47ba818c4baf2331ccd76ec2ef2 /meta-oe/recipes-extended
parent82dbf3f408ee92b5650629cfe8292407f21b5a5c (diff)
downloadmeta-openembedded-contrib-bc4d1aa833f62e1bc270eaed99dfd50c0f7abe3a.tar.gz
libqb: Upgrade to 1.0.1 release
Add a patch needed for cross compiling Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch43
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.1.bb (renamed from meta-oe/recipes-extended/libqb/libqb_0.17.2.bb)14
2 files changed, 49 insertions, 8 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch b/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch
new file mode 100644
index 0000000000..28bc5c07df
--- /dev/null
+++ b/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch
@@ -0,0 +1,43 @@
+From e6fbad0c122ba8e87b67a9e2447505adcaafe204 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 29 Mar 2017 16:31:38 -0700
+Subject: [PATCH] Remove runtime check for CLOCK_MONOTONIC
+
+Does not work during cross compile
+
+use a compile-time check to detect whether the
+monotonic clock is available. This check can run just fine when we are
+cross-compiling.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 12 ++++++++++--
+ 1 file changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fa13ae6..f4f0f46 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -175,9 +175,17 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+ )
+
+ AC_MSG_CHECKING(for a working clock_getres(CLOCK_MONOTONIC, &ts))
+-AC_RUN_IFELSE([AC_LANG_PROGRAM(
++AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+ [[#include <time.h>]],
+-[[struct timespec ts; if(clock_getres(CLOCK_MONOTONIC, &ts)) return -1;]])],
++[[
++#include <unistd.h>
++int main() {
++#if !(defined(_POSIX_MONOTONIC_CLOCK) && _POSIX_MONOTONIC_CLOCK >= 0 && defined(CLOCK_MONOTONIC))
++ #error No monotonic clock
++#endif
++ return 0;
++
++]])],
+ [
+ AC_MSG_RESULT([yes])
+ AC_DEFINE_UNQUOTED([HAVE_CLOCK_GETRES_MONOTONIC], 1, [Define to 1 if clock_getres(CLOCK_MONOTONIC, &ts) works])
+--
+2.12.1
+
diff --git a/meta-oe/recipes-extended/libqb/libqb_0.17.2.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.1.bb
index 94030b2ea0..e26bb7c19a 100644
--- a/meta-oe/recipes-extended/libqb/libqb_0.17.2.bb
+++ b/meta-oe/recipes-extended/libqb/libqb_1.0.1.bb
@@ -4,22 +4,20 @@ It provides high performance logging, tracing, ipc, and poll."
HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
SECTION = "libs"
-
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
-inherit autotools-brokensep pkgconfig
-
-PV = "0.17.2+git${SRCPV}"
+inherit autotools pkgconfig
-SRCREV = "bd2c587f6ccacd8a5644b275d99324d200c2b378"
-SRC_URI = "git://github.com/ClusterLabs/${BPN}.git"
+PV .= "+git${SRCPV}"
+SRCREV = "0a329683a76bc6aeb36f20f2bf6b43ba0440c4dc"
+SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
+ file://0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch \
+ "
S = "${WORKDIR}/git"
do_configure_prepend() {
( cd ${S}
${S}/autogen.sh )
}
-
-