aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-10 22:05:09 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-13 07:17:03 -0800
commitc174217540abebac63498cf2f8ae429662c15fec (patch)
tree4a087fbd633ed30b0e5d006203aca96426205e9e /meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
parent0d4a59268cc696171534f6ddfbedc91a2b3abf1a (diff)
downloadmeta-openembedded-contrib-c174217540abebac63498cf2f8ae429662c15fec.tar.gz
nodejs: use OE-provided compiler flags (arm)
This overrides yocto-provided build flags with its own, e.g we get arm-poky-linux-musleabi-g++ -mthumb -mfpu=neon -mfloat-abi=hard -mcpu=cortex-a7 \ ... \ -march=armv7-a -mfpu=neon -mfloat-abi=hard -marm Causing the latter to override the former, and compiler warnings: cc1plus: warning: switch '-mcpu=cortex-a7' conflicts with '-march=armv7-a' switch Patch this out, so that yocto-provided flags take precedence. Note that in reality the same should probably be done for all the other supported architectures, too. Note that this also switches to Thumb(2) mode (in my case). No obvious problems have been noted during compilation or runtime. Upstream-Status: Inappropriate [oe-specific] Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
index e384b62869..44c016a904 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
@@ -19,6 +19,7 @@ SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
file://0004-Make-compatibility-with-gcc-4.8.patch \
file://0005-Link-atomic-library.patch \
+ file://0007-v8-don-t-override-ARM-CFLAGS.patch \
"
SRC_URI_append_class-target = " \
file://0002-Using-native-torque.patch \