aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/meson
diff options
context:
space:
mode:
authorLinus Svensson <linussn@axis.com>2017-02-16 12:53:58 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-20 11:50:12 +0100
commitb8f6712bd98569df432d4e8eeb34a4182902a5b5 (patch)
tree7d7b6c3e6b47fff88bd89b5d9016e5ae49fd1a73 /meta-oe/recipes-devtools/meson
parenta1d02f972143647bb8094797982b643c1b375c1e (diff)
downloadmeta-openembedded-contrib-b8f6712bd98569df432d4e8eeb34a4182902a5b5.tar.gz
meson: Add recipe for the meson build system
Meson is a build system designed to be fast and as user firendly as possible. Find out more about meson at mesonbuild.com. This patch is based on a prototype patch by Ross Burton <ross.burton@intel.com>. Signed-off-by: Linus Svensson <linussn@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/meson')
-rw-r--r--meta-oe/recipes-devtools/meson/meson_0.36.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/meson/meson_0.36.0.bb b/meta-oe/recipes-devtools/meson/meson_0.36.0.bb
new file mode 100644
index 0000000000..9349fcbbc0
--- /dev/null
+++ b/meta-oe/recipes-devtools/meson/meson_0.36.0.bb
@@ -0,0 +1,18 @@
+HOMEPAGE = "http://mesonbuild.com"
+SUMMARY = "A high performance build system"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://github.com/mesonbuild/meson.git"
+
+SRCREV = "4e3073f90a7b4f225ce7d89034d61cd978399eba"
+PV = "0.36.0"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} = "ninja python3-core python3-modules"
+
+BBCLASSEXTEND = "native"