aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/debootstrap
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2015-09-30 10:37:28 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:28:14 +0200
commitdcba860726c64e9bfa7ed06d8bf141a562a97070 (patch)
tree3753aa337e3636227c7ab5a9f76efa4651821f2c /meta-oe/recipes-devtools/debootstrap
parentac27acf362060b60fb025ea3578858f2bce62425 (diff)
downloadmeta-openembedded-contrib-dcba860726c64e9bfa7ed06d8bf141a562a97070.tar.gz
meta-oe: recipes-devtools: add debootstrap recipe
debootstrap is a tool which will install a Debian base system into a subdirectory of another, already installed system. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/debootstrap')
-rw-r--r--meta-oe/recipes-devtools/debootstrap/debootstrap/devices.tar.gzbin0 -> 767 bytes
-rw-r--r--meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb25
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap/devices.tar.gz b/meta-oe/recipes-devtools/debootstrap/debootstrap/devices.tar.gz
new file mode 100644
index 0000000000..20eaba3ad2
--- /dev/null
+++ b/meta-oe/recipes-devtools/debootstrap/debootstrap/devices.tar.gz
Binary files differ
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
new file mode 100644
index 0000000000..3169e80111
--- /dev/null
+++ b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Install a Debian system into a subdirectory"
+HOMEPAGE = "https://wiki.debian.org/Debootstrap"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "debootstrap-custom-license"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
+
+inherit autotools pkgconfig
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI = "\
+ http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \
+ file://devices.tar.gz;unpack=0 \
+"
+
+SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a"
+SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_install_prepend() {
+ cp ${WORKDIR}/devices.tar.gz ${S}
+ cd "${S}"
+}