aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-10-02 17:33:58 +0000
committerKhem Raj <raj.khem@gmail.com>2018-10-02 17:17:10 -0700
commitff5549841c5c5debae0180574643281d25d4c037 (patch)
treef0ad36c7a5cebe52b8ac64a3be9747c4172280ee /meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
parent934a034e0ece3527652b6fa84c1590e6f5847073 (diff)
downloadmeta-openembedded-contrib-ff5549841c5c5debae0180574643281d25d4c037.tar.gz
android-tools: use patchdir parameter to apply patches
* helps to apply the patches for correct git repo * split remove-selinux-android.patch into 2, because devtool modify fails to apply it across 2 different git repositories: ERROR: Command Error: 'sh -c 'PATCHFILE="remove-selinux-android.patch" git -c user.name="OpenEmbedded" -c user.email="oe.patch@oe" commit -F /tmp/tmpvn7yf20j --author="Sergio Schvezov <sergio.schvezov@canonical.com>" --date="Wed, 7 Sep 2016 12:58:47 +0300"'' exited with 0 Output: On branch devtool Changes not staged for commit: modified: system/core (modified content) modified: system/extras (modified content) no changes added to commit ERROR: Function failed: patch_do_patch ERROR: Logfile of failure stored in: /OE/build/owpb/webos-ports/tmp-glibc/work/aarch64-webos-linux/android-tools/5.1.1.r37-r0/devtooltmp-7qrccor9/temp/log.do_patch.8643 NOTE: Tasks Summary: Attempted 3 tasks of which 0 didn't need to be rerun and 1 failed. NOTE: Writing buildhistory ERROR: Extracting source for android-tools failed * similarly with remove-bionic-android.patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb26
1 files changed, 14 insertions, 12 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index 74f2bf221e..1478c1205e 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -30,17 +30,21 @@ SRC_URI = " \
git://${LIBHARDWARE_REPO};name=libhardware;protocol=https;nobranch=1;destsuffix=git/hardware/libhardware \
git://${LIBSELINUX_REPO};name=libselinux;protocol=https;nobranch=1;destsuffix=git/external/libselinux \
git://${BUILD_REPO};name=build;protocol=https;nobranch=1;destsuffix=git/build \
- file://remove-selinux-android.patch \
- file://use-capability.patch \
- file://use-local-socket.patch \
+ file://remove-selinux-android.patch;patchdir=system/core \
+ file://use-capability.patch;patchdir=system/core \
+ file://use-local-socket.patch;patchdir=system/core \
+ file://mkbootimg-Add-dt-parameter-to-specify-DT-image.patch;patchdir=system/core \
+ file://remove-bionic-android.patch;patchdir=system/core \
+ file://define-shell-command.patch;patchdir=system/core \
+ file://implicit-declaration-function-strlcat-strlcopy.patch;patchdir=system/core \
+ file://fix-big-endian-build.patch;patchdir=system/core \
+ file://0001-add-base64-implementation.patch;patchdir=system/core \
+ file://0002-adb-Musl-fixes.patch;patchdir=system/core \
+ file://0001-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
+ file://0001-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
+ file://remove-selinux-android-extras.patch;patchdir=system/extras \
file://preserve-ownership.patch;patchdir=system/extras \
- file://mkbootimg-Add-dt-parameter-to-specify-DT-image.patch \
- file://remove-bionic-android.patch \
- file://define-shell-command.patch \
- file://implicit-declaration-function-strlcat-strlcopy.patch \
- file://fix-big-endian-build.patch \
- file://0001-add-base64-implementation.patch \
- file://0002-adb-Musl-fixes.patch \
+ file://remove-bionic-android-libselinux.patch;patchdir=external/libselinux \
file://android-tools-adbd.service \
file://.gitignore;subdir=git \
file://adb.mk;subdir=${BPN} \
@@ -48,8 +52,6 @@ SRC_URI = " \
file://ext4_utils.mk;subdir=${BPN} \
file://fastboot.mk;subdir=${BPN} \
file://mkbootimg.mk;subdir=${BPN} \
- file://0001-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
- file://0001-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
"
S = "${WORKDIR}/git"