aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-10-02 17:33:59 +0000
committerKhem Raj <raj.khem@gmail.com>2018-10-02 17:17:10 -0700
commit7ea8156eeaebd845321dd2189ef0c9c6b408acd5 (patch)
tree7826818d7fb7b893f19eb4d2acd40002fecdcbff /meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
parentff5549841c5c5debae0180574643281d25d4c037 (diff)
downloadmeta-openembedded-contrib-7ea8156eeaebd845321dd2189ef0c9c6b408acd5.tar.gz
android-tools: refresh patches with devtool
* devtool isn't able to regenerate them completely, it generates only top level commit which says that submodules were changed, like this: From c8fa114325e4e532657499b9bb6fd23cb6536eaa Mon Sep 17 00:00:00 2001 From: OpenEmbedded <oe.patch@oe> Date: Tue, 2 Oct 2018 16:46:55 +0000 Subject: [PATCH] Committing changes from do_patch --- external/libselinux | 2 +- system/core | 2 +- system/extras | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) .. but it still creates relatively good commits in each submodule and after small manual cleanup they can be exported with git format-patch --no-numbered --no-signature * rename .gitignore to prevent git ignoring the changes in .patch files in meta-oe already (we want to use it only later during the build) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb50
1 files changed, 24 insertions, 26 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index 1478c1205e..2604f65e1f 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -11,11 +11,6 @@ DEPENDS = "libbsd libpcre zlib libcap"
DEPENDS_append_class-target = " openssl10"
ANDROID_MIRROR = "android.googlesource.com"
-CORE_REPO = "${ANDROID_MIRROR}/platform/system/core"
-EXTRAS_REPO = "${ANDROID_MIRROR}/platform/system/extras"
-LIBHARDWARE_REPO = "${ANDROID_MIRROR}/platform/hardware/libhardware"
-LIBSELINUX_REPO = "${ANDROID_MIRROR}/platform/external/libselinux"
-BUILD_REPO = "${ANDROID_MIRROR}/platform/build"
# matches with android-5.1.1_r37
SRCREV_core = "2314b110bdebdbfd2d94c502282f9e57c849897e"
@@ -25,28 +20,28 @@ SRCREV_libselinux = "07e9e1339ad1ba608acfba9dce2d0f474b252feb"
SRCREV_build = "16e987def3d7d8f7d30805eb95cef69e52a87dbc"
SRC_URI = " \
- git://${CORE_REPO};name=core;protocol=https;nobranch=1;destsuffix=git/system/core \
- git://${EXTRAS_REPO};name=extras;protocol=https;nobranch=1;destsuffix=git/system/extras \
- git://${LIBHARDWARE_REPO};name=libhardware;protocol=https;nobranch=1;destsuffix=git/hardware/libhardware \
- git://${LIBSELINUX_REPO};name=libselinux;protocol=https;nobranch=1;destsuffix=git/external/libselinux \
- git://${BUILD_REPO};name=build;protocol=https;nobranch=1;destsuffix=git/build \
- file://remove-selinux-android.patch;patchdir=system/core \
- file://use-capability.patch;patchdir=system/core \
- file://use-local-socket.patch;patchdir=system/core \
- file://mkbootimg-Add-dt-parameter-to-specify-DT-image.patch;patchdir=system/core \
- file://remove-bionic-android.patch;patchdir=system/core \
- file://define-shell-command.patch;patchdir=system/core \
- file://implicit-declaration-function-strlcat-strlcopy.patch;patchdir=system/core \
- file://fix-big-endian-build.patch;patchdir=system/core \
- file://0001-add-base64-implementation.patch;patchdir=system/core \
- file://0002-adb-Musl-fixes.patch;patchdir=system/core \
- file://0001-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
- file://0001-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
- file://remove-selinux-android-extras.patch;patchdir=system/extras \
- file://preserve-ownership.patch;patchdir=system/extras \
- file://remove-bionic-android-libselinux.patch;patchdir=external/libselinux \
+ git://${ANDROID_MIRROR}/platform/system/core;name=core;protocol=https;nobranch=1;destsuffix=git/system/core \
+ git://${ANDROID_MIRROR}/platform/system/extras;name=extras;protocol=https;nobranch=1;destsuffix=git/system/extras \
+ git://${ANDROID_MIRROR}/platform/hardware/libhardware;name=libhardware;protocol=https;nobranch=1;destsuffix=git/hardware/libhardware \
+ git://${ANDROID_MIRROR}/platform/external/libselinux;name=libselinux;protocol=https;nobranch=1;destsuffix=git/external/libselinux \
+ git://${ANDROID_MIRROR}/platform/build;name=build;protocol=https;nobranch=1;destsuffix=git/build \
+ file://core/0001-adb-remove-selinux-extensions.patch;patchdir=system/core \
+ file://core/0002-adb-Use-local-sockets-where-appropriate.patch;patchdir=system/core \
+ file://core/0003-adb-define-shell-command.patch;patchdir=system/core \
+ file://core/0004-adb-Fix-build-on-big-endian-systems.patch;patchdir=system/core \
+ file://core/0005-adb-add-base64-implementation.patch;patchdir=system/core \
+ file://core/0006-adb-Musl-fixes.patch;patchdir=system/core \
+ file://core/0007-adb-usb_linux.c-fix-build-with-glibc-2.28.patch;patchdir=system/core \
+ file://core/0008-adb-Allow-adbd-to-be-ran-as-root.patch;patchdir=system/core \
+ file://core/0009-mkbootimg-Add-dt-parameter-to-specify-DT-image.patch;patchdir=system/core \
+ file://core/0010-Use-linux-capability.h-on-linux-systems-too.patch;patchdir=system/core \
+ file://core/0011-Remove-bionic-specific-calls.patch;patchdir=system/core \
+ file://core/0012-Fix-implicit-declaration-of-stlcat-strlcopy-function.patch;patchdir=system/core \
+ file://extras/0001-ext4_utils-remove-selinux-extensions.patch;patchdir=system/extras \
+ file://extras/0002-ext4_utils-add-o-argument-to-preserve-ownership.patch;patchdir=system/extras \
+ file://libselinux/0001-Remove-bionic-specific-calls.patch;patchdir=external/libselinux \
file://android-tools-adbd.service \
- file://.gitignore;subdir=git \
+ file://gitignore \
file://adb.mk;subdir=${BPN} \
file://adbd.mk;subdir=${BPN} \
file://ext4_utils.mk;subdir=${BPN} \
@@ -54,6 +49,7 @@ SRC_URI = " \
file://mkbootimg.mk;subdir=${BPN} \
"
+
S = "${WORKDIR}/git"
B = "${WORKDIR}/${BPN}"
@@ -76,6 +72,8 @@ TOOLS_class-native = "fastboot ext4_utils mkbootimg"
TOOLS_class-nativesdk = "fastboot ext4_utils mkbootimg"
do_compile() {
+ cp ${WORKDIR}/gitignore ${S}/.gitignore
+
# Setting both variables below causing our makefiles to not work with
# implicit make rules
unset CFLAGS