aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2016-11-18 12:50:40 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:29:55 +0100
commit4cd27df21d21650c8cf5468be36f33d49e4587cf (patch)
tree4c55600aa69f929e8a90a398f827c0ac16af0c7a /meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
parentb451e5444f7e4d927ef9bebc8af234429afcbb88 (diff)
downloadmeta-openembedded-contrib-4cd27df21d21650c8cf5468be36f33d49e4587cf.tar.gz
android-tools: fix do_install
The previous patch introduced 2 bugs that made packaging fail: 1) Always failing grep 2) Conditionally install systemd files Systemd.bbclass doesn't handle conditional installation and will throw an error. Tested with -native and regular cross builds. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb24
1 files changed, 15 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index 1769b6a8a7..a9e7d5d828 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -108,7 +108,7 @@ do_compile() {
}
do_install() {
- if [ grep -q "ext4_utils" "${TOOLS}" ] ; then
+ if echo ${TOOLS} | grep -q "ext4_utils" ; then
install -D -p -m0755 ${S}/system/core/libsparse/simg_dump.py ${D}${bindir}/simg_dump
install -D -p -m0755 ${S}/system/extras/ext4_utils/mkuserimg.sh ${D}${bindir}/mkuserimg
@@ -120,22 +120,28 @@ do_install() {
install -m0755 ${B}/ext4_utils/simg2simg ${D}${bindir}
fi
- if [ grep -q "adb " "${TOOLS}" ] ; then
- install -m0755 ${B}/adb/adb ${D}${bindir}i
+ if echo ${TOOLS} | grep -q "adb " ; then
+ install -d ${D}${bindir}
+ install -m0755 ${B}/adb/adb ${D}${bindir}
fi
- if [ grep -q "adbd" "${TOOLS}" ] ; then
+ if echo ${TOOLS} | grep -q "adbd" ; then
+ install -d ${D}${bindir}
install -m0755 ${B}/adbd/adbd ${D}${bindir}
- install -D -p -m0644 ${WORKDIR}/android-tools-adbd.service \
- ${D}${systemd_unitdir}/system/android-tools-adbd.service
fi
- if [ grep -q "fastboot" "${TOOLS}" ] ; then
+ # Outside the if statement to avoid errors during do_package
+ install -D -p -m0644 ${WORKDIR}/android-tools-adbd.service \
+ ${D}${systemd_unitdir}/system/android-tools-adbd.service
+
+ if echo ${TOOLS} | grep -q "fastboot" ; then
+ install -d ${D}${bindir}
install -m0755 ${B}/fastboot/fastboot ${D}${bindir}
fi
- if [ grep -q "mkbootimg" "${TOOLS}" ] ; then
- install -m0755 ${B}/mkbootimg/mkbootimg ${D}${bindir}
+ if echo ${TOOLS} | grep -q "mkbootimg" ; then
+ install -d ${D}${bindir}
+ install -m0755 ${B}/mkbootimg/mkbootimg ${D}${bindir}
fi
}