aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus/dbus-broker_18.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III via Openembedded-devel <openembedded-devel@lists.openembedded.org>2019-03-26 19:32:35 -0700
committerKhem Raj <raj.khem@gmail.com>2019-03-28 09:48:30 -0700
commite8e80ea28eed58903586f95edbd86657d8a2c564 (patch)
tree02f79765459fea4f884f9341619f2f381c216739 /meta-oe/recipes-core/dbus/dbus-broker_18.bb
parent07ee1b38f6e92f66de71286f43939f68ae79ecec (diff)
downloadmeta-openembedded-contrib-e8e80ea28eed58903586f95edbd86657d8a2c564.tar.gz
dbus-broker: 16 -> 18
Also brings in a patch to fix up building against a musl libc that is not in a released build yet. This change cleans up a number of things about the build - Upstream no longer depends on glib - We dont ever runtime depend on reference dbus - Docs are disabled by default so we don't need to specify the option - There is no native tooling so we shouldn't need a native bbclass - No longer depend on gitsm since upstream provides release tarballs Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/dbus/dbus-broker_18.bb')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker_18.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_18.bb b/meta-oe/recipes-core/dbus/dbus-broker_18.bb
new file mode 100644
index 0000000000..af9af182ae
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-broker_18.bb
@@ -0,0 +1,22 @@
+SUMMARY = "dbus broker"
+DESCRIPTION = "Drop-in replacement for dbus-daemon."
+
+SECTION = "base"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8"
+
+SRC_URI = "https://github.com/bus1/dbus-broker/releases/download/v${PV}/dbus-broker-${PV}.tar.xz"
+SRC_URI[sha256sum] = "f29e77a4d7b386e835dbe6379f4308f0503d6077834ba734ea6782359b34cbb9"
+SRC_URI_append_libc-musl = "file://0001-c-ini-Fix-missing-sys-types.h-includes.patch"
+
+inherit meson pkgconfig systemd distro_features_check
+
+DEPENDS = "expat systemd"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+SYSTEMD_SERVICE_${PN} = "${BPN}.service"
+
+FILES_${PN} += "${systemd_system_unitdir}"
+FILES_${PN} += "${systemd_user_unitdir}"