aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2018-11-25 20:55:36 +0200
committerKhem Raj <raj.khem@gmail.com>2018-11-27 11:05:21 -0800
commit92f0db817890bcc9e3710ce1be2be09d9c37d7a6 (patch)
tree3394be084dd54bdfffc31ad571a787e2ec3598da /meta-oe/recipes-connectivity
parent9a64b3805de82c813d89de92163129a84c2ebf97 (diff)
downloadmeta-openembedded-contrib-92f0db817890bcc9e3710ce1be2be09d9c37d7a6.tar.gz
Add czmq (C bindings for ZeroMQ)
Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/zeromq/czmq_4.1.1.bb30
-rw-r--r--meta-oe/recipes-connectivity/zeromq/files/0001-Problem-out-of-date-with-zproject.patch31
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/zeromq/czmq_4.1.1.bb b/meta-oe/recipes-connectivity/zeromq/czmq_4.1.1.bb
new file mode 100644
index 0000000000..f2db0041c7
--- /dev/null
+++ b/meta-oe/recipes-connectivity/zeromq/czmq_4.1.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "C bindings for ZeroMQ"
+HOMEPAGE = "http://www.zeromq.org"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+DEPENDS = "zeromq"
+
+SRC_URI = "https://github.com/zeromq/czmq/releases/download/v${PV}/czmq-${PV}.tar.gz \
+ file://0001-Problem-out-of-date-with-zproject.patch \
+"
+
+SRC_URI[md5sum] = "6d3a6fdd25c2bb29897c53670dce97bf"
+SRC_URI[sha256sum] = "f00ff419881dc2a05d0686c8467cd89b4882677fc56f31c0e2cc81c134cbb0c0"
+
+inherit cmake
+
+PACKAGES = "lib${BPN} lib${BPN}-dev lib${BPN}-staticdev ${PN} ${PN}-dbg"
+
+FILES_${PN} = "${bindir}/*"
+FILES_lib${BPN} = "${libdir}/*.so.*"
+FILES_lib${BPN}-dev = "${libdir}/*.so ${libdir}/pkgconfig ${includedir}"
+FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
+
+RDEPENDS_lib${BPN}-dev = "zeromq-dev"
+
+PACKAGECONFIG ??= "lz4 uuid"
+PACKAGECONFIG[lz4] = ",-DCMAKE_DISABLE_FIND_PACKAGE_lz4=TRUE,lz4"
+PACKAGECONFIG[uuid] = ",-DCMAKE_DISABLE_FIND_PACKAGE_uuid=TRUE,util-linux"
+
+BBCLASSEXTEND = "nativesdk"
+
diff --git a/meta-oe/recipes-connectivity/zeromq/files/0001-Problem-out-of-date-with-zproject.patch b/meta-oe/recipes-connectivity/zeromq/files/0001-Problem-out-of-date-with-zproject.patch
new file mode 100644
index 0000000000..5f5702c8c8
--- /dev/null
+++ b/meta-oe/recipes-connectivity/zeromq/files/0001-Problem-out-of-date-with-zproject.patch
@@ -0,0 +1,31 @@
+From d155ffd33630f80b23c31b3a6e01da221dd9bd13 Mon Sep 17 00:00:00 2001
+From: Luca Boccassi <luca.boccassi@gmail.com>
+Date: Fri, 30 Mar 2018 16:36:22 +0100
+Subject: [PATCH] Problem: out of date with zproject
+
+Upstream-Status: backport
+Signed-off-by: Adrian Bunk <bunk@stusta.de>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a3b81722..4f203461 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,7 +38,7 @@ if (NOT CMAKE_BUILD_TYPE)
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+ )
+ message(STATUS "git workspace root [${git_result}]: ${git_root}")
+- if ( "${git_result}" == "0" )
++ if ( "${git_result}" STREQUAL "0" )
+ set (CMAKE_BUILD_TYPE Debug)
+ else ()
+ set (CMAKE_BUILD_TYPE Release)
+@@ -608,7 +608,7 @@ add_custom_command(
+ TARGET distclean
+ )
+
+-include(ClangFormat)
++include(ClangFormat OPTIONAL)
+
+ ########################################################################
+ # summary
+