aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-09-01 15:35:12 +1200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2017-09-01 15:57:45 +1200
commit385dfd3c60bcebaf2b96ad65b75b1ce07f706be3 (patch)
tree3eb4a6d77b699da9a641a1d45ce4eaccfbedc688 /meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch
parent83099ac9a7c5ea6b57afea40e164f78b98f8fe96 (diff)
downloadmeta-openembedded-contrib-385dfd3c60bcebaf2b96ad65b75b1ce07f706be3.tar.gz
paho-mqtt-c: add recipe from meta-intel-iot-middleware and updatepaule/mqtt-recipes
The following improvements have been made over the recipe that was in meta-intel-iot-middleware (a layer which is no longer actively maintained): * Upgrade to 1.2.0. The version number being used previously (3.1) was bogus - I guess someone saw that it supported the MQTT *protocol* version 3.1 and assumed that was the library version. Since we are renaming it to paho-mqtt-c at the same time to distinguish it from other Eclipse Paho MQTT library flavours, we don't need to bump PE. * Fix SRC_URI since the repository has been moved * Fix "No GNU_HASH in the elf binary" QA error * Add notice.html and about.html to LIC_FILES_CHKSUM since they cover licensing * Add description, Signed-off-by and Upstream-Status to makefile.patch * Set short description in SUMMARY * Drop unnecessary custom do_compile - the default implementation basically does the same thing * Drop RDEPENDS on openssl - linking already ensures runtime dependencies get set correctly * Move DEPENDS further up Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch')
-rw-r--r--meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch b/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch
new file mode 100644
index 0000000000..a31bfaa749
--- /dev/null
+++ b/meta-oe/recipes-connectivity/paho-mqtt-c/files/makefile.patch
@@ -0,0 +1,25 @@
+Disable building some things we don't need
+
+Upstream-Status: Inappropriate [config]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 33bd2d0..84262bd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -115,7 +115,8 @@ LDFLAGS_AS = -shared -Wl,-soname,lib${MQTTLIB_AS}.so.${MAJOR_VERSION} -lpthread
+
+ all: build
+
+-build: | mkdir ${MQTTLIB_C_TARGET} ${MQTTLIB_CS_TARGET} ${MQTTLIB_A_TARGET} ${MQTTLIB_AS_TARGET} ${MQTTVERSION_TARGET} ${SYNC_SAMPLES} ${ASYNC_SAMPLES} ${SYNC_TESTS} ${SYNC_SSL_TESTS} ${ASYNC_TESTS} ${ASYNC_SSL_TESTS}
++build: | mkdir ${MQTTLIB_C_TARGET} ${MQTTLIB_CS_TARGET} ${MQTTLIB_A_TARGET} ${MQTTLIB_AS_TARGET}
++#${MQTTVERSION_TARGET} ${SYNC_SAMPLES} ${ASYNC_SAMPLES} ${SYNC_TESTS} ${SYNC_SSL_TESTS} ${ASYNC_TESTS} ${ASYNC_SSL_TESTS}
+
+ clean:
+ rm -rf ${blddir}/*
+--