aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2015-04-28 12:17:55 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-11 10:25:53 +0200
commit3ad735b7e26d5f2acc7452de563db93f8d10340c (patch)
tree98409e2b628dfa1f37c8bd4f19d368b713f77c8f /meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
parente7e67108df29927e3ebc5e9566dbbcd3a6e553b0 (diff)
downloadmeta-openembedded-contrib-3ad735b7e26d5f2acc7452de563db93f8d10340c.tar.gz
bluez collection: add (moved from oe-core)
BlueZ 4.x Bluetooth stack has been removed from oe-core. However, it is still supported, so add it to recipes-connectivity in meta-oe. meta-systemd layer bluez4 bbappend has been integrated into bluez4 recipe. In order to use it in oe-core/poky/YP, 'bluez5' backfill distro feature needs to be disabled via: DISTRO_FEATURES_BACKFILL_CONSIDERED = "bluez5" . 'bluetooth' distro feature needs to be present also. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb')
-rw-r--r--meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb b/meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
new file mode 100644
index 0000000000..6a16520168
--- /dev/null
+++ b/meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
@@ -0,0 +1,39 @@
+require bluez4.inc
+require recipes-multimedia/gstreamer/gst-plugins-package.inc
+
+PR = "r1"
+
+SRC_URI[md5sum] = "fb42cb7038c380eb0e2fa208987c96ad"
+SRC_URI[sha256sum] = "59738410ade9f0e61a13c0f77d9aaffaafe49ba9418107e4ad75fe52846f7487"
+
+DEPENDS = "bluez4 gst-plugins-base"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+"
+
+# clean unwanted files
+do_install_append() {
+ rm -rf ${D}${bindir}
+ rm -rf ${D}${sbindir}
+ rm -f ${D}${libdir}/lib*
+ rm -rf ${D}${libdir}/pkgconfig
+ rm -rf ${D}${sysconfdir}
+ rm -rf ${D}${base_libdir}
+ rm -rf ${D}${libdir}/bluetooth
+ rm -rf ${D}${localstatedir}
+ rm -rf ${D}${libdir}/alsa-lib
+ rm -rf ${D}${datadir}
+ rm -rf ${D}${includedir}
+ rm -rf ${D}${nonarch_base_libdir}
+}
+
+FILES_${PN} = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/gstreamer-0.10/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/*/.debug \
+"
+