aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-11-14 12:56:27 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-15 11:01:54 -0500
commit1c8720a130f07dec3f7d05d0d26bba7b0def5aa2 (patch)
tree295b5ff4b6fab87afda6136721d95eea0ea3c8de /meta-networking
parent0f817b124e82ae01f9e1f8b8640f08bfaa52aad6 (diff)
downloadmeta-openembedded-contrib-1c8720a130f07dec3f7d05d0d26bba7b0def5aa2.tar.gz
ifenslave: make option '-h' work
When pass option '-h' or '--help' to ifenslave, it calls 'exec man 8 ifenslave' to show help information. But the manual page is missing and then outputs nothing. Install the manual page and split it to ifenslave rather than ifenslave-doc to make option '-h' of ifenslave work. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ifenslave/ifenslave_2.7.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ifenslave/ifenslave_2.7.bb b/meta-networking/recipes-support/ifenslave/ifenslave_2.7.bb
index 7473b0dafa..50289211b3 100644
--- a/meta-networking/recipes-support/ifenslave/ifenslave_2.7.bb
+++ b/meta-networking/recipes-support/ifenslave/ifenslave_2.7.bb
@@ -17,4 +17,10 @@ do_install() {
install -m 0755 -D ${S}/debian/ifenslave.if-pre-up ${D}${sysconfdir}/network/if-pre-up.d/ifenslave
install -m 0755 -D ${S}/debian/ifenslave.if-post-down ${D}${sysconfdir}/network/if-post-down.d/ifenslave
install -m 0755 -D ${S}/debian/ifenslave.if-up ${D}${sysconfdir}/network/if-up.d/ifenslave
+ install -m 0644 -D ${S}/debian/ifenslave.8 ${D}${mandir}/man8/ifenslave.8
}
+
+FILES_${PN}-doc_remove = "${mandir}"
+FILES_${PN} += "${mandir}/man8/ifenslave.8"
+
+RDEPENDS_${PN} = "man"