aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-11-20 21:31:49 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-21 17:51:37 -0800
commit4c00e5fed9532fe6ee71ce96b0124fc234b44d4e (patch)
treeec74c3e49a545e37a85befe3d7f970304af5516c /meta-networking
parentb77cc676916e7cf06e5a80081aac52a7bdc7d3a9 (diff)
downloadmeta-openembedded-contrib-4c00e5fed9532fe6ee71ce96b0124fc234b44d4e.tar.gz
recipes: rename distro_features_check to features_check
Avoid warning due to the class rename in OE-Core. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.10.10.bb2
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.33.bb2
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb2
-rw-r--r--meta-networking/recipes-extended/dlm/dlm_4.0.9.bb2
-rw-r--r--meta-networking/recipes-protocols/dante/dante_1.4.1.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.10.10.bb b/meta-networking/recipes-connectivity/samba/samba_4.10.10.bb
index e002a9da5a..1ad5d55aca 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.10.10.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.10.10.bb
@@ -45,7 +45,7 @@ RDEPENDS_${PN}_remove = "perl"
DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb libbsd libaio libpam libtasn1 jansson"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "pam"
DEPENDS_append_libc-musl = " libtirpc"
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
index 19cfe46b7b..6ff103c770 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
@@ -20,7 +20,7 @@ SRC_URI = " \
SRC_URI[md5sum] = "3747b453d76709e5a99da209fc0bb5f5"
SRC_URI[sha256sum] = "5f85a8084ad3539b547bec097286948233188c971f498890316dec170bdd1da8"
-inherit setuptools distro_features_check
+inherit setuptools features_check
RDEPENDS_${PN} = " \
iptables \
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
index 8523ae8c0d..6b73506c2a 100644
--- a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
@@ -7,7 +7,7 @@ AUTHOR = "Clayton Craft and others"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
-inherit distro_features_check systemd
+inherit features_check systemd
RDEPENDS_${PN} = "python3-pygobject python3-dbus"
REQUIRED_DISTRO_FEATURES = "systemd"
diff --git a/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb b/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
index 6345c8141b..4bf9944aad 100644
--- a/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
+++ b/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
@@ -23,7 +23,7 @@ S = "${WORKDIR}/dlm-dlm-${PV}"
DEPENDS = "corosync systemd"
-inherit pkgconfig systemd distro_features_check
+inherit pkgconfig systemd features_check
PACKAGECONFIG ??= ""
diff --git a/meta-networking/recipes-protocols/dante/dante_1.4.1.bb b/meta-networking/recipes-protocols/dante/dante_1.4.1.bb
index ffdab22cf0..cfe71dd69d 100644
--- a/meta-networking/recipes-protocols/dante/dante_1.4.1.bb
+++ b/meta-networking/recipes-protocols/dante/dante_1.4.1.bb
@@ -25,7 +25,7 @@ EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}"
DEPENDS += "flex-native bison-native libpam"
-inherit autotools-brokensep distro_features_check
+inherit autotools-brokensep features_check
REQUIRED_DISTRO_FEATURES = "pam"