aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mediacenter/kodi
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2017-02-16 12:20:26 +0100
committerAndreas Oberritter <obi@opendreambox.org>2017-06-26 22:59:20 +0200
commitbb1c4558df8ccdc933ee22bd92426b621777cd9b (patch)
tree0fcdc78689aeb14b5bbf48129476bad21f64e0d2 /meta-multimedia/recipes-mediacenter/kodi
parent68e97db4084a182d3f8e8c70bc896c49d66171a4 (diff)
downloadmeta-openembedded-contrib-bb1c4558df8ccdc933ee22bd92426b621777cd9b.tar.gz
kodi: fix build with ffmpeg-3.0
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta-multimedia/recipes-mediacenter/kodi')
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi-17/0013-VideoPlayer-Fix-build-with-FFmpeg-3.0.patch36
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0013-VideoPlayer-Fix-build-with-FFmpeg-3.0.patch b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0013-VideoPlayer-Fix-build-with-FFmpeg-3.0.patch
new file mode 100644
index 0000000000..1801b4ede0
--- /dev/null
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0013-VideoPlayer-Fix-build-with-FFmpeg-3.0.patch
@@ -0,0 +1,36 @@
+From 1ed8235081aece5b2ffe1861b1568a1e31d65de6 Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@opendreambox.org>
+Date: Thu, 16 Feb 2017 12:18:01 +0100
+Subject: [PATCH] VideoPlayer: Fix build with FFmpeg 3.0
+
+---
+ xbmc/cores/VideoPlayer/DVDDemuxers/DVDDemuxFFmpeg.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/xbmc/cores/VideoPlayer/DVDDemuxers/DVDDemuxFFmpeg.cpp b/xbmc/cores/VideoPlayer/DVDDemuxers/DVDDemuxFFmpeg.cpp
+index 33d1e5a..579f65b 100644
+--- a/xbmc/cores/VideoPlayer/DVDDemuxers/DVDDemuxFFmpeg.cpp
++++ b/xbmc/cores/VideoPlayer/DVDDemuxers/DVDDemuxFFmpeg.cpp
+@@ -1513,7 +1513,7 @@ CDemuxStream* CDVDDemuxFFmpeg::AddStream(int streamIdx)
+ if (!langTag)
+ {
+ // only for avi audio streams
+- if ((strcmp(m_pFormatContext->iformat->name, "avi") == 0) && (pStream->codecpar->codec_type == AVMEDIA_TYPE_AUDIO))
++ if ((strcmp(m_pFormatContext->iformat->name, "avi") == 0) && (pStream->codec->codec_type == AVMEDIA_TYPE_AUDIO))
+ {
+ // only defined for streams 1 to 9
+ if((streamIdx > 0) && (streamIdx < 10))
+@@ -1791,10 +1791,10 @@ unsigned int CDVDDemuxFFmpeg::HLSSelectProgram()
+ {
+ int idx = m_pFormatContext->programs[i]->stream_index[j];
+ AVStream* pStream = m_pFormatContext->streams[idx];
+- if (pStream && pStream->codecpar &&
+- pStream->codecpar->codec_type == AVMEDIA_TYPE_VIDEO)
++ if (pStream && pStream->codec &&
++ pStream->codec->codec_type == AVMEDIA_TYPE_VIDEO)
+ {
+- strRes = pStream->codecpar->width * pStream->codecpar->height;
++ strRes = pStream->codec->width * pStream->codec->height;
+ }
+ }
+
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
index 6d8f2a2043..46a316b40a 100644
--- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
@@ -74,6 +74,7 @@ SRC_URI = "git://github.com/xbmc/xbmc.git;branch=Krypton \
file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \
file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \
file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \
+ file://0013-VideoPlayer-Fix-build-with-FFmpeg-3.0.patch \
"
SRC_URI_append_libc-musl = " \