aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:37 +0200
commit558d935806365784794edc2c8473dffcc1db6b86 (patch)
treeb24d5b6ef2834c6544eb6310aa6675f3867064ca /meta-gnome
parent3fd61331a4c22377dd5a46ff37a9ef20fc381aa5 (diff)
downloadmeta-openembedded-contrib-558d935806365784794edc2c8473dffcc1db6b86.tar.gz
libbonobo: Fix missing dep on orbit2-native and build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo.inc2
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch26
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb1
3 files changed, 28 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
index e0f6168694..60a85974ed 100644
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
@@ -3,7 +3,7 @@ LICENSE = "GPLv2 & LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
SECTION = "x11/gnome/libs"
-DEPENDS = "glib-2.0 orbit2 intltool-native libxml2 dbus dbus-glib"
+DEPENDS = "glib-2.0 orbit2-native orbit2 intltool-native libxml2 dbus dbus-glib"
inherit gnomebase gtk-doc lib_package
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch
new file mode 100644
index 0000000000..20db671e05
--- /dev/null
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch
@@ -0,0 +1,26 @@
+This checks whether the format string is a literal on the calling function. As bonobo_debug_print()
+takes already a va_list, we specify the format on the functions that call it
+The second number, which is 0 here, should then be the argument index of the variadic argument
+
+Fixed warning with clang
+
+| ../../libbonobo-2.32.1/bonobo/bonobo-debug.c:58:32: error: format string is not a string literal [-Werror,-Wformat-nonliteral]
+| vfprintf (_bonobo_debug_file, fmt, args);
+| ^~~
+| 1 error generated.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libbonobo-2.32.1/bonobo/bonobo-debug.c
+===================================================================
+--- libbonobo-2.32.1.orig/bonobo/bonobo-debug.c
++++ libbonobo-2.32.1/bonobo/bonobo-debug.c
+@@ -47,6 +47,7 @@ bonobo_debug_init(void)
+ _bonobo_debug_file = stderr;
+ }
+
++__attribute__((__format__ (printf, 2, 0)))
+ void
+ bonobo_debug_print (const char *name, char *fmt, ...)
+ {
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb
index fd4d812105..8e00eb4d2d 100644
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb
@@ -2,6 +2,7 @@ require libbonobo.inc
SRC_URI += "file://0001-Remove-use-of-G_DISABLE_DEPRECATED.patch \
file://do-not-use-srcdir-variable.patch \
+ file://fix-nonliteral-in-string.patch \
"
SRC_URI[archive.md5sum] = "27fa902d4fdf6762ee010e7053aaf77b"
SRC_URI[archive.sha256sum] = "9160d4f277646400d3bb6b4fa73636cc6d1a865a32b9d0760e1e9e6ee624976b"