aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-07-31 04:15:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-08 13:46:48 +0200
commit2c8645249e27f40a42c9d6edaec0d6292d618f07 (patch)
tree94b90caf6e5afc035716815b9f1c0a0a12c7907c /meta-gnome
parente9bf73f8671bba516a0c5c5d0bc450316df06f41 (diff)
downloadmeta-openembedded-contrib-2c8645249e27f40a42c9d6edaec0d6292d618f07.tar.gz
libgnomeui: update to 2.24.5 / fix build on gcc6 / cleanup
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnomeui/0001-suppress-string-format-literal-warning-to-fix-build-.patch78
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.3.bb10
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.5.bb (renamed from meta-gnome/recipes-gnome/libgnome/libgnomeui.inc)11
3 files changed, 86 insertions, 13 deletions
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnomeui/0001-suppress-string-format-literal-warning-to-fix-build-.patch b/meta-gnome/recipes-gnome/libgnome/libgnomeui/0001-suppress-string-format-literal-warning-to-fix-build-.patch
new file mode 100644
index 0000000000..abc9bdfbab
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgnome/libgnomeui/0001-suppress-string-format-literal-warning-to-fix-build-.patch
@@ -0,0 +1,78 @@
+From 6697fcf9d7f53126b442bf19890640b5f88c8aa4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Fri, 29 Jul 2016 21:24:20 +0200
+Subject: [PATCH] suppress string format literal warning to fix build with gcc6
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+works around:
+| ../../libgnomeui-2.24.5/libgnomeui/gnome-dateedit.c: In function 'day_selected':
+| ../../libgnomeui-2.24.5/libgnomeui/gnome-dateedit.c:156:9: error: format not a string literal, format string not checked [-Werror=format-nonliteral]
+| strftime_date_format, &mtm) == 0)
+| ^~~~~~~~~~~~~~~~~~~~
+| ../../libgnomeui-2.24.5/libgnomeui/gnome-dateedit.c: In function 'gnome_date_edit_set_time':
+| ../../libgnomeui-2.24.5/libgnomeui/gnome-dateedit.c:704:2: error: format not a string literal, format string not checked [-Werror=format-nonliteral]
+| if (strftime (buffer, sizeof (buffer), strftime_date_format, mytm) == 0)
+| ^~
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ libgnomeui/gnome-dateedit.c | 6 ++++++
+ libgnomeui/gnome-gconf-ui.c | 3 +++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/libgnomeui/gnome-dateedit.c b/libgnomeui/gnome-dateedit.c
+index 69ab699..41541c3 100644
+--- a/libgnomeui/gnome-dateedit.c
++++ b/libgnomeui/gnome-dateedit.c
+@@ -152,9 +152,12 @@ day_selected (GtkCalendar *calendar, GnomeDateEdit *gde)
+ else
+ mtm.tm_year = year;
+
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ if (strftime (buffer, sizeof (buffer),
+ strftime_date_format, &mtm) == 0)
+ strcpy (buffer, "???");
++#pragma GCC diagnostic pop
+ buffer[sizeof(buffer)-1] = '\0';
+
+ /* FIXME: what about set time */
+@@ -701,8 +704,11 @@ gnome_date_edit_set_time (GnomeDateEdit *gde, time_t the_time)
+ mytm = localtime (&the_time);
+
+ /* Set the date */
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ if (strftime (buffer, sizeof (buffer), strftime_date_format, mytm) == 0)
+ strcpy (buffer, "???");
++#pragma GCC diagnostic pop
+ buffer[sizeof(buffer)-1] = '\0';
+
+ str_utf8 = g_locale_to_utf8 (buffer, -1, NULL, NULL, NULL);
+diff --git a/libgnomeui/gnome-gconf-ui.c b/libgnomeui/gnome-gconf-ui.c
+index 43c0f44..a84b2c0 100644
+--- a/libgnomeui/gnome-gconf-ui.c
++++ b/libgnomeui/gnome-gconf-ui.c
+@@ -180,12 +180,15 @@ error_idle_func (gpointer data)
+ "configuration settings may not work properly.");
+ }
+
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ dialog = gtk_message_dialog_new (NULL /* parent */,
+ 0 /* flags */,
+ GTK_MESSAGE_ERROR,
+ GTK_BUTTONS_OK,
+ fmt,
+ gnome_program_get_human_readable_name(gnome_program_get()));
++#pragma GCC diagnostic pop
+ gtk_dialog_set_default_response (GTK_DIALOG (dialog), GTK_RESPONSE_OK);
+ g_signal_connect (dialog, "response",
+ G_CALLBACK (gtk_widget_destroy),
+--
+2.5.5
+
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.3.bb b/meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.3.bb
deleted file mode 100644
index 3208a81700..0000000000
--- a/meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.3.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require libgnomeui.inc
-
-PR = "r1"
-
-SRC_URI[archive.md5sum] = "ceab6f4370581d1a03c09f15cc103099"
-SRC_URI[archive.sha256sum] = "04c81f3bb5a337cdf3ed1230916f82d29857ee95eb884f58dd2f5c6860efe803"
-GNOME_COMPRESS_TYPE="bz2"
-
-# http://errors.yoctoproject.org/Errors/Details/68607/
-PNBLACKLIST[libgnomeui] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnomeui.inc b/meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.5.bb
index 26997b851d..b94f3da799 100644
--- a/meta-gnome/recipes-gnome/libgnome/libgnomeui.inc
+++ b/meta-gnome/recipes-gnome/libgnome/libgnomeui_2.24.5.bb
@@ -12,13 +12,18 @@ FILES_${PN} += "${libdir}/gtk-2.0/*/filesystems/lib*.so \
${datadir}/pixmaps/gnome-about-logo.png"
FILES_${PN}-dev += "${libdir}/gtk-2.0/*/filesystems/*.la ${libdir}/gtk-2.0/*/filesystems/*.a ${libdir}/libglade/*/*.la"
FILES_${PN}-staticdev += "${libdir}/libglade/*/*.a"
-FILES_${PN}-dbg += "${libdir}/gtk-2.0/*/filesystems/.debug/ ${libdir}/libglade/*/.debug/"
-SRC_URI += "file://gnome-stock-pixbufs.h file://no-pixbuf-csource.patch"
+SRC_URI += " \
+ file://0001-suppress-string-format-literal-warning-to-fix-build-.patch \
+ file://gnome-stock-pixbufs.h \
+ file://no-pixbuf-csource.patch \
+"
+SRC_URI[archive.md5sum] = "d4bb506b1916015323928faab5aa708b"
+SRC_URI[archive.sha256sum] = "ae352f2495889e65524c979932c909f4629a58e64290fb0c95333373225d3c0f"
+GNOME_COMPRESS_TYPE="bz2"
EXTRA_OECONF = "--disable-gtk-doc"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/gnome-stock-pixbufs.h ${S}/libgnomeui/pixmaps/gnome-stock-pixbufs.h
}
-