aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-01-17 09:34:11 +0100
committerArmin Kuster <akuster808@gmail.com>2018-01-22 19:40:02 -0800
commitdb39cbcd42d523892012935f3d6972f62e4b0a35 (patch)
tree4b6b3336b8b8c58b34a32f63c8ce6348463e743b /meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
parent8742b94ae895b58d0b179f6bb106a26cc2cb25ef (diff)
downloadmeta-openembedded-contrib-db39cbcd42d523892012935f3d6972f62e4b0a35.tar.gz
evolution-data-server: update 3.2.3 -> 3.26.3
In recent meta-universe 3.2.3 started to fail with: | camel-enumtypes.c:42:7: error: expected expression at end of input | { 512, "CAMEL_FOLDER_SHARED_BY_ME", "shared-by-me" }, | ^ Instead of cleaning I decided to update. The following changed: * eds builds with cmake instead of autotools * musl: I checked src/time/strftime.c and it seems strftime does not support '%l' / '%k'. musl-case was added to be a good boy but was not tested. * remove 0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch: src/camel/providers/imapx/camel-imapx-tokens.txt has text-only format these days * remove 0002-Fix-for-automake-1.12.x.patch: autotools was replaced by cmake * remove 0003-Disable-Werror-for-automake.patch: autotools was replaced by cmake * remove 0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch: autotools was replaced by cmake * remove 0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch: src/calendar/backends/caldav/e-cal-backend-caldav.c was reworked competely * remove 0006-configure.ac-do-not-overwrite-localedir.patch: autotools was replaced by cmake Tested: abiword build and run Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
new file mode 100644
index 0000000000..c8dc7e12c6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
@@ -0,0 +1,53 @@
+From 210b204d9edd71202454ff04013cc52b23c598e4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Tue, 19 Dec 2017 16:55:13 +0100
+Subject: [PATCH] CMakeLists.txt: remove CHECK_C_SOURCE_RUNS check
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+* TRY_RUN: does not work for OE
+* HAVE_LKSTRFTIME is set by recipe as configure option
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ CMakeLists.txt | 23 -----------------------
+ 1 file changed, 23 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a2396f2..f3b271b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -573,29 +573,6 @@ CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
+ CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
+ int main(void) { char *detail = nl_langinfo (_NL_ADDRESS_COUNTRY_AB2); return 0; }" HAVE__NL_ADDRESS_COUNTRY_AB2)
+
+-# *******************************************************
+-# Check to see if strftime supports the use of %l and %k
+-# *******************************************************
+-
+-CHECK_C_SOURCE_RUNS("
+- #include <stdlib.h>
+- #include <string.h>
+- #include <time.h>
+- int main(int argc, char **argv) {
+- char buf[10];
+- time_t rawtime;
+- struct tm *timeinfo;
+-
+- time(&rawtime);
+- timeinfo=localtime(&rawtime);
+- buf[0] = 0;
+- strftime(buf, 10, \"%lx%k\", timeinfo);
+-
+- if (!buf[0] || buf[0] == 'x' || strstr(buf, \"l\") || strstr(buf, \"k\"))
+- return 1;
+- return 0;
+- }" HAVE_LKSTRFTIME)
+-
+ # ******************************
+ # system mail stuff
+ # ******************************
+--
+2.14.3
+