aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-05 08:33:21 -0400
committerKhem Raj <raj.khem@gmail.com>2018-09-05 13:59:16 -0700
commit98e284846c9929dbaeddeb77ad2271f18fd85bdc (patch)
tree99d63d113282bb70b3cb40c316ce75ffca266460
parentc6a235aab14a7e83d6d8e32584bf8973b46a7acb (diff)
downloadmeta-openembedded-contrib-98e284846c9929dbaeddeb77ad2271f18fd85bdc.tar.gz
sblim-sfcb: do not use 'exit 1' to postpone to first boot
Since `939f7f1 meta/lib/oe/rootfs.py: do not execute defer_to_first_boot when processing postinst_intercept hooks' applied in oe-core, use defer_to_first_boot rather than `exit 1' to postpone to first boot Remove duplicated `systemctl enable', it is done in systemd.bbclass Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index ffbe7ea1b4..91c50027d8 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -68,14 +68,8 @@ do_install() {
}
pkg_postinst_${PN} () {
- OPTS=""
-
if [ x"$D" != "x" ]; then
- OPTS="--root=$D"
- if type systemctl >/dev/null 2>/dev/null; then
- systemctl $OPTS ${SYSTEMD_AUTO_ENABLE} ${SYSTEMD_SERVICE}
- fi
- exit 1
+ $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX}
fi
${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb