aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-06-10 17:08:09 +0200
committerKhem Raj <raj.khem@gmail.com>2018-06-14 08:57:14 -0700
commit5f31db6014082a16c0be8553b6388ff5f12428bd (patch)
tree38bcaaa479dc509a689c032c9455263bd103a9e2
parent13f311d88ffda574f3c0e3b70b8fbe3907c5629f (diff)
downloadmeta-openembedded-contrib-5f31db6014082a16c0be8553b6388ff5f12428bd.tar.gz
xfce4-panel: upgrade 4.12.2 -> 4.13.3
It is a development release but stoppers could not be found. * Uses GTK3 * Fixes background color in systray panel-plugin Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch42
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch (renamed from meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch)26
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb (renamed from meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.2.bb)13
3 files changed, 18 insertions, 63 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch
deleted file mode 100644
index 9dca3ba57d..0000000000
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From c582338ef4f33b3dc07a2636340d55b9fb530650 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
-Date: Wed, 17 Feb 2016 00:15:44 +0100
-Subject: [PATCH] clock-time: make change of system's timezone change time for
- DEFAULT_TIMEZONE
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-clock_time->timezone is set in clock_time_init so the condition
-
-'clock_time->timezone != NULL
-
-is matching always.
-
-Tested by selecting seconds displayed (-> quick update) and changing timezone.
-
-Upstream-Status: Submitted [1]
-
-[1] https://bugzilla.xfce.org/show_bug.cgi?id=12453
-
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
----
- plugins/clock/clock-time.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugins/clock/clock-time.c b/plugins/clock/clock-time.c
-index b015b13..4459b85 100644
---- a/plugins/clock/clock-time.c
-+++ b/plugins/clock/clock-time.c
-@@ -198,7 +198,7 @@ clock_time_get_time (ClockTime *clock_time)
-
- panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), NULL);
-
-- if (clock_time->timezone != NULL)
-+ if (g_strcmp0 (clock_time->timezone_name, DEFAULT_TIMEZONE) != 0)
- date_time = g_date_time_new_now (clock_time->timezone);
- else
- date_time = g_date_time_new_now_local ();
---
-2.5.0
-
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
index b2d960c003..1adb14552d 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
@@ -14,23 +14,23 @@ Upstream-Status: Pending
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
---
- plugins/windowmenu/windowmenu.c | 12 ++++++------
- 1 files changed, 6 insertions(+), 6 deletions(-)
+ plugins/windowmenu/windowmenu.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c
-index c96123a..9404021 100644
+index f47e993e..061d6544 100644
--- a/plugins/windowmenu/windowmenu.c
+++ b/plugins/windowmenu/windowmenu.c
-@@ -256,7 +256,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
+@@ -251,7 +251,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
g_signal_connect (G_OBJECT (plugin->button), "toggled",
G_CALLBACK (window_menu_plugin_menu), plugin);
-- plugin->icon = xfce_panel_image_new_from_source ("user-desktop");
-+ plugin->icon = xfce_panel_image_new_from_source (NULL);
+- plugin->icon = gtk_image_new_from_icon_name ("user-desktop", GTK_ICON_SIZE_BUTTON);
++ plugin->icon = gtk_image_new_from_icon_name (NULL, GTK_ICON_SIZE_BUTTON);
gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon);
gtk_widget_show (plugin->icon);
}
-@@ -634,7 +634,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
+@@ -640,7 +640,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
/* skip 'fake' windows */
type = wnck_window_get_window_type (window);
if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK)
@@ -39,22 +39,22 @@ index c96123a..9404021 100644
/* get the window icon and set the tooltip */
gtk_widget_set_tooltip_text (GTK_WIDGET (icon),
-@@ -648,11 +648,11 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
+@@ -660,12 +660,12 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
}
else
{
- show_desktop_icon:
+ show_no_icon:
-- /* desktop is shown right now */
-- xfce_panel_image_set_from_source (icon, "user-desktop");
+ /* desktop is shown right now */
+- gtk_image_set_from_icon_name (GTK_IMAGE (icon), "user-desktop", icon_size);
++ gtk_image_set_from_icon_name (GTK_IMAGE (icon), NULL, icon_size);
+ gtk_image_set_pixel_size (GTK_IMAGE (icon), icon_size);
- gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("Desktop"));
-+ /* no icon is shown right now */
-+ xfce_panel_image_set_from_source (icon, NULL);
+ gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("No Windows"));
}
}
}
--
-1.7.6.5
+2.14.3
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.2.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
index 9cc9a4bbce..dea0c357e2 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.2.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
@@ -2,21 +2,18 @@ SUMMARY = "Xfce4 Panel"
SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
-DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck"
+DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck3 vala-native"
-inherit xfce gtk-doc distro_features_check gtk-icon-cache
+inherit xfce gtk-doc gobject-introspection distro_features_check gtk-icon-cache
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI[md5sum] = "803c9aabc2925dc97f96de125c52ba2e"
-SRC_URI[sha256sum] = "42058abb81b8f87691d3999627447de71c3285bcf055f308aab5cefab2de0ce9"
+SRC_URI[md5sum] = "0ccb448e3792949eb0ae9db8dc22789b"
+SRC_URI[sha256sum] = "b467feb7ee9797ad12f56a152570e42a96b94ad63580d45536aabee282440ce8"
SRC_URI += " \
- file://0001-clock-time-make-change-of-system-s-timezone-change-t.patch \
- file://0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
+ file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
"
-EXTRA_OECONF += "--enable-gtk3"
-
python populate_packages_prepend() {
plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
plugin_name = d.expand('${PN}-plugin-%s')