aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-01-05 18:12:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-25 15:58:53 +0100
commit43b62423d6e21a893ad7fd00993e2a7f8aaad8a6 (patch)
tree67fdb479ea8ca586d0821bec81e2b5248768f013
parentea4abd908f4feadd17741e1f3431bb7825e69630 (diff)
downloadmeta-openembedded-contrib-43b62423d6e21a893ad7fd00993e2a7f8aaad8a6.tar.gz
python-chardet: provide both python2 and python3 packages
Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rwxr-xr-xmeta-python/recipes-devtools/python/python-chardet.inc8
-rwxr-xr-x[-rw-r--r--]meta-python/recipes-devtools/python/python-chardet_2.3.0.bb10
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-chardet_2.3.0.bb2
3 files changed, 12 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-chardet.inc b/meta-python/recipes-devtools/python/python-chardet.inc
new file mode 100755
index 0000000000..60305e8d8e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-chardet.inc
@@ -0,0 +1,8 @@
+SUMMARY = "Universal encoding detector for Python 2 and 3"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+inherit pypi
+
+SRC_URI[md5sum] = "25274d664ccb5130adae08047416e1a8"
+SRC_URI[sha256sum] = "e53e38b3a4afe6d1132de62b7400a4ac363452dc5dfcf8d88e8e0cce663c68aa"
diff --git a/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb b/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb
index dfc979b335..b7a46e9d7b 100644..100755
--- a/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python-chardet_2.3.0.bb
@@ -1,8 +1,2 @@
-SUMMARY = "Universal encoding detector for Python 2 and 3"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
-
-SRC_URI[md5sum] = "25274d664ccb5130adae08047416e1a8"
-SRC_URI[sha256sum] = "e53e38b3a4afe6d1132de62b7400a4ac363452dc5dfcf8d88e8e0cce663c68aa"
-
-inherit pypi setuptools
+inherit setuptools
+require python-chardet.inc
diff --git a/meta-python/recipes-devtools/python/python3-chardet_2.3.0.bb b/meta-python/recipes-devtools/python/python3-chardet_2.3.0.bb
new file mode 100755
index 0000000000..038043c568
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-chardet_2.3.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-chardet.inc