aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2019-11-07 23:27:16 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-07 17:43:44 -0800
commit412a93a1c15f78e9aa9ff4771b76d9a50f8cf758 (patch)
tree84e364b91bf1785f5a55ffc2f2b33bdd88a14d5b
parentd8ab89a24b9350a045bfe0faa31b9545061ce092 (diff)
downloadmeta-openembedded-contrib-412a93a1c15f78e9aa9ff4771b76d9a50f8cf758.tar.gz
ostree: fix some invalid condition checking
- PTEST_ENABLED is a target specific variable, avoid to check that for ostree-native recipe. - one of soup, curl PACKAGECONFIG would satisfy not running into the problem https://github.com/ostreedev/ostree/issues/1897, it should not stick to soup. For instance, the curl is being chosen in meta-updater rather than soup. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2019.5.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb b/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
index 035b4bb886..b3b34a15e6 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
@@ -182,10 +182,10 @@ SYSTEMD_SERVICE_${PN}-switchroot = "ostree-prepare-root.service"
BBCLASSEXTEND = "native"
python __anonymous() {
- if bb.utils.contains('PTEST_ENABLED', '1', 'True', 'False', d):
- if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
+ if not bb.data.inherits_class('native', d) and bb.utils.contains('PTEST_ENABLED', '1', 'True', 'False', d):
+ if not bb.utils.contains_any('BBFILE_COLLECTIONS', 'meta-python', 'True', 'False', d):
raise bb.parse.SkipRecipe('ptest requires meta-python to be present.')
- elif 'soup' not in d.getVar('PACKAGECONFIG').split():
+ elif not bb.utils.contains_any('PACKAGECONFIG', 'soup curl', 'True', 'False', d):
raise bb.parse.SkipRecipe('ptest requires soup enabled in PACKAGECONFIG.')
elif not oe.utils.any_distro_features(d, "xattr"):
raise bb.parse.SkipRecipe('ptest requires xattr enabled in DISTRO_FEATURES.')