aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2020-01-23 16:59:13 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-23 14:16:25 -0800
commita7f5aed4e5514b30ad230cdad03e05ab2e8597f1 (patch)
treee8d68db4a8cbac52b34f44494595032a62958b24
parent354bedc9aba9a79936b2ace8e39ab07352ad2d73 (diff)
downloadmeta-openembedded-contrib-a7f5aed4e5514b30ad230cdad03e05ab2e8597f1.tar.gz
plymouth: fix usrmerge
When usrmerge is enabled plymouth still tries to install to /bin and /lib leading to the following build error: ERROR: plymouth-git-r0 do_package: QA Issue: plymouth: Files/directories were installed but not shipped in any package: /sbin/plymouthd /lib/libply.so.5 /lib/libply.so /lib/libply.so.5.0.0 /lib/libply-splash-core.so /lib/libply-splash-core.so.5.0.0 /lib/libply-splash-core.so.5 /bin/plymouth There is a configuration flag --with-system-root-install which controls where the binaries get installed. The flag is currently tied to the systemd distro feature, however, this seems wrong. Use the flag to control where binaries get installed depending on whether usrmerge is used. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.4.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.4.bb
index 305977e5e1..8b71c2bd6c 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.4.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.4.bb
@@ -26,7 +26,8 @@ SRC_URI[sha256sum] = "4a197a4f1a05785d7453dd829b231352fb2d09171bd86c5ffaafbb2dd6
EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
--with-logo=${LOGO} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge','--without-system-root-install','--with-system-root-install',d)} \
"
PACKAGECONFIG ??= "pango initrd"