aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFagundes, Paulo <paulohefagundes@gmail.com>2020-07-06 11:34:27 -0600
committerKhem Raj <raj.khem@gmail.com>2020-07-06 13:57:38 -0700
commit74f2b5780dd29b9128be8b24208daa859b08e706 (patch)
treebdebd8f46713af82c38418f5f7adab593018118b
parent8447ad3d2538ee1ebe90798f84abc52590e2926e (diff)
downloadmeta-openembedded-contrib-74f2b5780dd29b9128be8b24208daa859b08e706.tar.gz
redis-plus-plus: add recipe
redis-plus-plus is a redis client written in C++ and based on hiredis Signed-off-by: Paulo Fagundes <paulohefagundes@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb
new file mode 100644
index 0000000000..e23733b0f8
--- /dev/null
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "C++ client for Redis based on hiredis"
+HOMEPAGE = "https://github.com/sewenew/redis-plus-plus"
+SECTION = "libs"
+
+DEPENDS += "hiredis"
+RDEPENDS_${PN} += "hiredis"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+SRCREV = "b08b36a9a91de00636e583307610f49af7876f50"
+SRC_URI = "git://github.com/sewenew/redis-plus-plus"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_SOLIBSDEV = ""
+FILES_${PN} += " ${libdir}/libredis++.so"