aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-10-08 17:18:49 +0100
committerKhem Raj <raj.khem@gmail.com>2020-10-18 12:45:33 -0700
commit5af46f89fcef5c436786ed81978de60f26abe054 (patch)
treeb1e192e6a2cb6b3b7d8f2a3e925465bbf46d5244
parentf688f94614edde062f8a6a361a01b8a19b21e972 (diff)
downloadmeta-openembedded-contrib-5af46f89fcef5c436786ed81978de60f26abe054.tar.gz
mpv: fetch waf in do_fetch
The mpv git repository doesn't include a copy of waf, instead there is a bootstrap script to fetch it. This recipe calls the bootstrap script in a do_patch postfunc, but downloading should be done in do_fetch. Instead of calling ./bootstrap.sh simply add waf to the SRC_URI so that Bitbake can use the mirrors/proxies/caching/checksum functionality. This is both better code and also works in buildtools environments where urllib2 can't make secure connections without configuration. [ YOCTO #14073 ] Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mpv_0.32.0.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mpv_0.32.0.bb b/meta-oe/recipes-multimedia/mplayer/mpv_0.32.0.bb
index 057f9c6f3b..973a978b1c 100644
--- a/meta-oe/recipes-multimedia/mplayer/mpv_0.32.0.bb
+++ b/meta-oe/recipes-multimedia/mplayer/mpv_0.32.0.bb
@@ -18,7 +18,9 @@ LICENSE_FLAGS = "commercial"
SRCREV_mpv = "70b991749df389bcc0a4e145b5687233a03b4ed7"
SRC_URI = " \
git://github.com/mpv-player/mpv;name=mpv \
+ https://waf.io/waf-2.0.20;name=waf;subdir=git \
"
+SRC_URI[waf.sha256sum] = "bf971e98edc2414968a262c6aa6b88541a26c3cd248689c89f4c57370955ee7f"
S = "${WORKDIR}/git"
@@ -100,14 +102,10 @@ EXTRA_OECONF = " \
${PACKAGECONFIG_CONFARGS} \
"
-do_patch[postfuncs] += "get_waf"
-
-get_waf() {
- cd ${S}
- ./bootstrap.py
- sed -i -e 's|/usr/bin/env python|/usr/bin/env python3|g' ${S}/waf
- cd -
+link_waf() {
+ ln -s waf-2.0.20 ${S}/waf
}
+do_unpack[postfuncs] += "link_waf"
FILES_${PN} += " \
${datadir}/icons \